summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStefan Schmidt <s.schmidt@samsung.com>2014-08-01 09:56:29 +0200
committerStefan Schmidt <s.schmidt@samsung.com>2014-08-01 09:56:29 +0200
commitf6c39d782cbf63541659bbb4f178fb1d6943e86e (patch)
treea9bc14183ed132c4f3981ec2bcc7b994bcb23911 /configure.ac
parent384849feca5d43343ce86608ad498d1906725e70 (diff)
downloadelementary-f6c39d782cbf63541659bbb4f178fb1d6943e86e.tar.gz
build: Avoid -shared LDFLAG to allow me to have a working distcheck
The -shared option in LDFLAG somehow is poisoning the configure run inside distcheck. This results in the compiler test getting a segfault and failing. I would really like to understand why this is needed to be set here manually anyway. Same for fPIC and dPIC. I would expect that we leave this to the user compiling the code or the packager. Skimming through the log only brought up fixing c++11 globally. Not really a commit message that helps me to understand why this is needed...
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 6188c0561..bd4bb2551 100644
--- a/configure.ac
+++ b/configure.ac
@@ -246,7 +246,7 @@ if test "x${HAVE_CXX11}" = "x1" -a "x${want_cxx11}" = "xyes"; then
evas-cxx >= efl_version \
"
have_cxx11="yes"
- LDFLAGS="${LDFLAGS} -shared -fPIC -DPIC"
+ LDFLAGS="${LDFLAGS} -fPIC -DPIC"
CXXFLAGS="${CXXFLAGS} -fPIC -DPIC"
],
[have_cxx11="no"]