summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorYouness Alaoui <kakaroto@kakaroto.homelinux.net>2011-10-15 09:48:50 +0000
committerYouness Alaoui <kakaroto@kakaroto.homelinux.net>2011-10-15 09:48:50 +0000
commit8f6f7b8583018e3d36f0d140e6730eca21a10658 (patch)
tree725e134c1ed26dcc3d6ef3d76e4f4d004edce130 /src/Makefile.am
parent182c478ef7111745da52c14faf57fdc9da4a66af (diff)
downloadelementary-8f6f7b8583018e3d36f0d140e6730eca21a10658.tar.gz
Elementary: Do not build modules if dlopen is not available on the system
SVN revision: 64094
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 8c0d71693..abaa75d7d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,4 +1,10 @@
AUTOMAKE_OPTIONS = 1.4 foreign
MAINTAINERCLEANFILES = Makefile.in
-SUBDIRS = lib bin modules edje_externals examples
+SUBDIRS = lib bin
+
+if BUILD_MODULES
+SUBDIRS += modules edje_externals
+endif
+
+SUBDIRS += examples