summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorCarsten Haitzler <raster@rasterman.com>2000-12-13 23:44:24 +0000
committerCarsten Haitzler <raster@rasterman.com>2000-12-13 23:44:24 +0000
commite79f8efd516224a00a442846ae7811652fb4a474 (patch)
tree663de28bc2ec8f4fdb8108adf8ef108a65899945 /Makefile.am
parent36bfc191e60633b3d8185b57bd4b4274263cf818 (diff)
downloadenlightenment-e79f8efd516224a00a442846ae7811652fb4a474.tar.gz
clean up the data section for some organisation.. in preparation for e to have
proper abstractions to finding the right data files depending on user config etc. SVN revision: 3987
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 2 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index 6826ca2736..44cdcf700e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -12,9 +12,7 @@ install-data-local:
if test -d $(srcdir)/data; then \
$(mkinstalldirs) $(DESTDIR)$(pkgdatadir)/data; \
for d in $(srcdir)/data/*; do \
- if test -f $$d; then \
- $(INSTALL_DATA) $$d $(DESTDIR)$(pkgdatadir)/data; \
- fi \
+ cp -ar $$d $(DESTDIR)$(pkgdatadir)/data; \
done \
fi
@@ -22,9 +20,7 @@ dist-hook:
if test -d data; then \
mkdir $(distdir)/data; \
for d in data/*; do \
- if test -f $$d; then \
- cp -p $$d $(distdir)/d; \
- fi \
+ cp -ar $$d $(distdir)/data; \
done \
fi