summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorCarsten Haitzler (Rasterman) <raster@rasterman.com>2019-07-12 14:09:55 +0100
committerCarsten Haitzler (Rasterman) <raster@rasterman.com>2019-07-12 14:14:28 +0100
commit385a91841c9f25f99cbe1371f2cddbf6c253abc8 (patch)
tree8a9fa23a2b00cf3e1622f1e181e980d389fd9673 /meson.build
parentd0f66258bed7bd949af6c0e74e95d7ac5bf900e3 (diff)
downloadenlightenment-385a91841c9f25f99cbe1371f2cddbf6c253abc8.tar.gz
meson opt - also match options change in core meson build
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index dea80a16bf..e573ec8e3c 100644
--- a/meson.build
+++ b/meson.build
@@ -275,7 +275,7 @@ dep_emotion = dependency('emotion' , required: true)
dep_elementary = dependency('elementary' , required: true)
dep_wayland = []
-if get_option('wayland') == true
+if get_option('wl') == true
wayland_protocols = dependency('wayland-protocols', version: '>= 1.12')
dir_wayland_protocols = wayland_protocols.get_pkgconfig_variable('pkgdatadir')
wayland_version = '>= 1.11.0'
@@ -318,7 +318,7 @@ if get_option('wayland') == true
endif
dep_ecore_x = []
-if get_option('wayland') == true and get_option('wl-x11') == false and get_option('xwayland') == false
+if get_option('wl') == true and get_option('wl-x11') == false and get_option('xwayland') == false
config_h.set('HAVE_WAYLAND_ONLY', '1')
else
dep_ecore_x = dependency('ecore-x')