summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMarcel Hollerbach <marcel-hollerbach@t-online.de>2017-08-10 15:31:33 +0200
committerMarcel Hollerbach <marcel-hollerbach@t-online.de>2017-08-10 15:31:33 +0200
commit4af2976a54a479868bc3576a892809ce05fb132a (patch)
tree6bea9027b59f66533d2c77648d1a922a4ae010ce /meson.build
parent186674facd2c87f69bb8462ed0071686f897fa01 (diff)
downloadenlightenment-4af2976a54a479868bc3576a892809ce05fb132a.tar.gz
meson: add HAVE_DRM2 and HAVE_WL_DRM
for now i just added HAVE_WL_DRM but its just the same as USE_MODULE_WL_DRM, maybe we can replace HAVE_WL_DRM once autotools is gone, so we have a clear pattern.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 7eedf82bfd..bfcd4dc9af 100644
--- a/meson.build
+++ b/meson.build
@@ -244,6 +244,13 @@ if get_option('mount-eeze') == true
endif
endif
+if get_option('wayland') == true
+ if get_option('wl-drm')
+ dep_ecore_drm2 = dependency('ecore-drm2', required : true)
+ config_h.set('HAVE_DRM2', '1')
+ endif
+endif
+
dep_rt = cc.find_library('rt', required: false)
dep_eina = dependency('eina' , required: true, version: efl_version)
dep_eet = dependency('eet' , required: true)