summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorCarsten Haitzler (Rasterman) <raster@rasterman.com>2018-03-20 18:53:15 +0900
committerCarsten Haitzler (Rasterman) <raster@rasterman.com>2018-03-20 18:53:15 +0900
commit76eeffa2f681eebfb685faff2322defbfdffb3da (patch)
tree9697d33da6c42c86c9f2ded98de1427edfbbd209 /meson.build
parenta77951f8231cf1160d089065cb483addb7f769b3 (diff)
downloadenlightenment-76eeffa2f681eebfb685faff2322defbfdffb3da.tar.gz
build - make pam a requirement on non-bsd unless disabled
this shou,ld provide a compile failure for when no pam headers are found and thus pam not enabled if we need pam for auth (i.e. linux). so it'll be harder to foot-shoot now.also an add-on fix to T6779
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 3cdb499c68..f947e9fde3 100644
--- a/meson.build
+++ b/meson.build
@@ -191,6 +191,10 @@ if get_option('pam') == true
if cc.has_header('security/pam_appl.h')
config_h.set('HAVE_PAM', '1')
dep_pam = cc.find_library('pam', required: true)
+ else
+ if openbsd == false and freebsd == false
+ error('PAM is not disabled and not found on non-free+open BSD platforms')
+ endif
endif
endif