summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorCarsten Haitzler (Rasterman) <raster@rasterman.com>2017-07-27 18:30:11 +0900
committerCarsten Haitzler (Rasterman) <raster@rasterman.com>2017-07-27 18:30:11 +0900
commit822a0bcacbce6e960a4456405108723ec448eb60 (patch)
treec3ffb498590cb67eaa8219b9592d6b56080251e3 /meson.build
parentf6d9eeb99a55e5dcfd3a943fcea9dfafaa993d1b (diff)
downloadenlightenment-822a0bcacbce6e960a4456405108723ec448eb60.tar.gz
e module build - make ibar and clock really simple and generic
now their build fiels are super easy to maintan. we should expand this kind of ptterning aross the e build and then expand it to handle new patters where needed like custom binaries (setuid or not), etc etc.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 4 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 6c6c0fe951..85b84baf90 100644
--- a/meson.build
+++ b/meson.build
@@ -400,10 +400,12 @@ subdir('src/bin')
module_files = []
module_ldflags = '-module -avoid-version'
module_includes = ['../../..', '../../bin', '../../bin/efx']
+module_includes2 = [ '../..', '../bin', '../bin/efx' ]
module_deps = [deps_e, dep_dl]
-subdir('src/modules/ibar')
-subdir('src/modules/clock')
+subdir('src/modules')
+#subdir('src/modules/ibar')
+#subdir('src/modules/clock')
subdir('src/modules/pager')
subdir('src/modules/pager_plain')
subdir('src/modules/battery')