summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorCarsten Haitzler (Rasterman) <raster@rasterman.com>2017-08-10 20:22:55 +0900
committerCarsten Haitzler (Rasterman) <raster@rasterman.com>2017-08-10 23:14:12 +0900
commitc80766dfa275a60b2047701d816e2f45395e75dd (patch)
treed2db38700825205f2275a8a241ee2d4fdab7b6ab /meson.build
parentbcf0110277cc01250f34eb8babecda33f8230ca1 (diff)
downloadenlightenment-c80766dfa275a60b2047701d816e2f45395e75dd.tar.gz
e meson build - refactor and clean up config and some module only cfg
config that is only needed fro modules only needs to be don in the modules subdir meson.build... i tried doing what modules do but output files cant have paths.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build20
1 files changed, 4 insertions, 16 deletions
diff --git a/meson.build b/meson.build
index bfcd4dc9af..a23cdbaaaa 100644
--- a/meson.build
+++ b/meson.build
@@ -82,7 +82,7 @@ config_h.set('_ALL_SOURCE' , '1')
config_h.set('_POSIX_PTHREAD_SEMANTICS', '1')
config_h.set('_TANDEM_SOURCE' , '1')
config_h.set('__EXTENSIONS__' , '1')
-#config_h.set('E_RELEASE_BUILD', '1')
+#config_h.set('E_RELEASE_BUILD' , '1')
if get_option('nls') == true
subdir('po')
@@ -302,13 +302,13 @@ if get_option('wayland') == true
])
wayland_scanner = find_program('wayland-scanner')
gen_scanner_client = generator(wayland_scanner,
- output: '@BASENAME@-client-protocol.h',
+ output : '@BASENAME@-client-protocol.h',
arguments: ['client-header', '@INPUT@', '@OUTPUT@'])
gen_scanner_server = generator(wayland_scanner,
- output: '@BASENAME@-server-protocol.h',
+ output : '@BASENAME@-server-protocol.h',
arguments: ['server-header', '@INPUT@', '@OUTPUT@'])
gen_scanner_impl = generator(wayland_scanner,
- output: '@BASENAME@-protocol.c',
+ output : '@BASENAME@-protocol.c',
arguments: ['code', '@INPUT@', '@OUTPUT@'])
config_h.set('HAVE_WAYLAND', '1')
endif
@@ -325,11 +325,6 @@ if dep_xkeyboard_config.found() == true
config_h.set_quoted('XKB_BASE', dep_xkeyboard_config.get_pkgconfig_variable('xkb_base'))
endif
-eet = find_program('eet')
-gen_eet = generator(eet,
- output: '@BASENAME@.cfg',
- arguments: ['-e', '@OUTPUT@', 'config', '@INPUT@', '1'])
-
eldbus_codegen = find_program('eldbus-codegen')
requires_e = []
@@ -341,12 +336,6 @@ endif
subdir('src/bin')
-module_files = []
-module_ldflags = '-module -avoid-version'
-module_includes = [ '../../..', '../../bin', '../../bin/efx' ]
-module_includes2 = [ '../..' , '../bin' , '../bin/efx' ]
-module_deps = [ deps_e, dep_dl ]
-
subdir('src/modules')
subdir('config')
@@ -376,7 +365,6 @@ pkgconfig.generate(name : proj,
description : 'Enlightenment Window Manager',
filebase : proj,
subdirs : proj,
- #requires: deps_e,
requires : requires_e,
version : e_version_rev,
libraries_private: '-lm',