summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorCarsten Haitzler (Rasterman) <raster@rasterman.com>2020-08-04 09:50:55 +0100
committerCarsten Haitzler (Rasterman) <raster@rasterman.com>2020-08-04 09:50:55 +0100
commitcb887d063f85f1949a11c6d6c5809141c1fae214 (patch)
tree438ea8621818296fe9f464a52a8a3f64d2eaea44 /meson.build
parent94ad423d6eaaa6ec2e7dd01fcfbcf0490dc76352 (diff)
downloadenlightenment-cb887d063f85f1949a11c6d6c5809141c1fae214.tar.gz
e - systemd -= as long as enabled allow to build without it
we know where service files SHOULD go... and soif systemd is not there to tell us, put them in the known place. this is so the non0systemd os's can buand should build with the support but its all runtime detected/enabled already. this means that actually no one should need tyo go disable systemd support in builds. it's all runtime.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 6 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 5027d542c9..7cfc277e34 100644
--- a/meson.build
+++ b/meson.build
@@ -242,8 +242,12 @@ systemd_unitdir = ''
if get_option('systemd') == true
systemd_unitdir = get_option('systemdunitdir')
if systemd_unitdir == ''
- dep_systemd = dependency('systemd', required: true)
- systemd_unitdir = dep_systemd.get_pkgconfig_variable('systemduserunitdir')
+ dep_systemd = dependency('systemd', required: false)
+ if dep_systemd.found()
+ systemd_unitdir = dep_systemd.get_pkgconfig_variable('systemduserunitdir')
+ else
+ systemd_unitdir = join_paths(dir_lib, 'systemd', 'user')
+ endif
endif
endif