summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorCarsten Haitzler (Rasterman) <raster@rasterman.com>2018-05-17 03:11:37 +0900
committerCarsten Haitzler (Rasterman) <raster@rasterman.com>2018-05-18 21:45:20 +0900
commitf20762a82d1ade3dac10ef175f78c2777b97260e (patch)
tree1912225548d009523e0d164559040706f95262d6 /meson.build
parent5a1e9a995ca691139405b6a9bc2edc6ec427fe54 (diff)
downloadenlightenment-f20762a82d1ade3dac10ef175f78c2777b97260e.tar.gz
meson - fix dir_sysconf to be under the prefix as it was not
dir_sysconf was set to "etc". not even a /. this meant enlightenment_sys couldnt find/load sysactions.conf as it used a non-relocatable fixed location due to security (setuid root) reasons.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 62714857c6..9fc72e4214 100644
--- a/meson.build
+++ b/meson.build
@@ -47,6 +47,10 @@ dir_module_e = join_paths(dir_lib, proj, 'modules')
dir_util_e = join_paths(dir_lib, proj, 'utils')
dir_pc = join_paths(dir_data, 'pkgconfig')
+if dir_sysconf == 'etc'
+ dir_sysconf = join_paths(dir_prefix, dir_sysconf)
+endif
+
suid_exes = []
pkgconfig = import('pkgconfig')