summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorCarsten Haitzler (Rasterman) <raster@rasterman.com>2020-01-12 21:38:54 +0000
committerCarsten Haitzler (Rasterman) <raster@rasterman.com>2020-01-15 11:33:49 +0000
commitf57572b678f20d269cd1ea474a42c2eb4c727221 (patch)
tree68a18716bd59d9cbd76cf4ecb6a91a600b28d93f /meson.build
parentdda50e8d8778762a315a556b74040c60190fda67 (diff)
downloadenlightenment-f57572b678f20d269cd1ea474a42c2eb4c727221.tar.gz
e system - add new uber setuid tool to replace all the previous ones
so e has had a bit of a mess of setuid root tools to do things that are essential to maintaing a functioning desktop/laptop/tablet/phone like device like shutting it down or suspending or sqizzling the cpu governor or messing with the backlight or... you get the idea. this has been spread around enlightenment_sys and other special purpose tools. this now unifies it into a single "always there" enlightenment_system backend setuid root slave process whose job it is to do all these things via a stdio protocol in an organized way. this means latency to do something is lower, but at the expense of consuming ram and a lurking process. unfortunately the lurking will be needed soon when i add ddc support to make it even vaguely efficient, so it's a cost i guess we have to pay now. we'll need this in future as well for some stats collection and more. still need to port existing code to use this instead of the existing stuff, and then remove of the old stuff.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index b3ae22b1f1..a1fa4ae15d 100644
--- a/meson.build
+++ b/meson.build
@@ -147,6 +147,13 @@ config_h.set_quoted('PACKAGE_NAME' , proj)
config_h.set_quoted('BINDIR' , dir_bin)
config_h.set_quoted('DATADIR' , dir_data)
+if cc.has_header('sys/prctl.h') == true
+ config_h.set('HAVE_PRCTL' , '1')
+endif
+if cc.has_header('sys/procctl.h') == true
+ config_h.set('HAVE_PROCCTL' , '1')
+endif
+
if cc.has_function('setenv') == true
config_h.set('HAVE_SETENV' , '1')
endif