summaryrefslogtreecommitdiff
path: root/src/modules/connman/Makefile.am
diff options
context:
space:
mode:
authorCarsten Haitzler <raster@rasterman.com>2008-08-31 01:51:27 +0000
committerCarsten Haitzler <raster@rasterman.com>2008-08-31 01:51:27 +0000
commit9d7329da99437412f202a923ca5c62235e3ba9b4 (patch)
treec420bd4f3cdcc1dd986e489424294033a54e365b /src/modules/connman/Makefile.am
parent7d1f2a01746761d33bd4ff2e4af0ff58599ba051 (diff)
downloadenlightenment-9d7329da99437412f202a923ca5c62235e3ba9b4.tar.gz
some mixer fixes (icon, code), a connman module - beware. not fully working
(well working up to the point whre you can select a network - at that point connman itself just stares dumbly at you and does nothing - so right now it's some form of connman bug i suspect). it doesnt save config or load - so you need to re-init each time and the graphcis are... let's just say.. sucky. for now theyare test graphics only. suto-connect if network found etc. doesnt work as well.. can't even connect first time... i can clean the rest up so in theory it works - but in practice, won't be useful until connmand (back end) works properly. SVN revision: 35755
Diffstat (limited to 'src/modules/connman/Makefile.am')
-rw-r--r--src/modules/connman/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/src/modules/connman/Makefile.am b/src/modules/connman/Makefile.am
new file mode 100644
index 0000000000..be48417b87
--- /dev/null
+++ b/src/modules/connman/Makefile.am
@@ -0,0 +1,33 @@
+MAINTAINERCLEANFILES = Makefile.in
+MODULE = connman
+
+# data files for the module
+filesdir = $(libdir)/enlightenment/modules/$(MODULE)
+files_DATA = \
+e-module-$(MODULE).edj module.desktop
+
+EXTRA_DIST = $(files_DATA)
+
+# the module .so file
+INCLUDES = -I. \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/src/modules/$(MODULE) \
+ -I$(top_srcdir)/src/bin \
+ -I$(top_srcdir)/src/lib \
+ -I$(top_srcdir)/src/modules \
+ @e_cflags@
+
+pkgdir = $(libdir)/enlightenment/modules/$(MODULE)/$(MODULE_ARCH)
+pkg_LTLIBRARIES = module.la
+
+module_la_SOURCES = e_mod_main.h \
+ e_mod_main.c \
+ e_iface.h \
+ e_iface.c
+
+module_la_LIBADD = @e_libs@ @dlopen_libs@ @E_DBUS_LIBS@
+module_la_LDFLAGS = -module -avoid-version
+module_la_DEPENDENCIES = $(top_builddir)/config.h
+
+uninstall:
+ rm -rf $(DESTDIR)$(libdir)/enlightenment/modules/$(MODULE)