summaryrefslogtreecommitdiff
path: root/src/modules/packagekit/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/modules/packagekit/meson.build')
-rw-r--r--src/modules/packagekit/meson.build24
1 files changed, 24 insertions, 0 deletions
diff --git a/src/modules/packagekit/meson.build b/src/modules/packagekit/meson.build
new file mode 100644
index 0000000000..2fdb959887
--- /dev/null
+++ b/src/modules/packagekit/meson.build
@@ -0,0 +1,24 @@
+packagekit_src = [
+ 'e_mod_config.c',
+ 'e_mod_main.c',
+ 'e_mod_packagekit.c',
+ 'e_mod_config.h',
+ 'e_mod_main.h',
+ 'e_mod_packagekit.h',
+]
+
+packagekit_dir = join_paths(dir_module_e, 'packagekit', module_arch)
+if get_option('packagekit') == true
+ config_h.set('USE_MODULE_PACKAGEKIT', '1')
+
+ module_files += join_paths(packagekit_dir, 'packagekit.so')
+ shared_module('packagekit',
+ packagekit_src,
+ include_directories: include_directories(module_includes),
+ name_prefix: '',
+ dependencies: module_deps,
+ install_dir: packagekit_dir,
+ install: true
+ )
+endif
+