summaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL15
1 files changed, 15 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
new file mode 100644
index 0000000..672131b
--- /dev/null
+++ b/Makefile.PL
@@ -0,0 +1,15 @@
+use 5.006;
+use ExtUtils::MakeMaker;
+
+WriteMakefile(
+ NAME => 'Error',
+ VERSION_FROM => 'lib/Error.pm',
+ PREREQ_PM =>
+ {
+ 'Scalar::Util' => 0,
+ 'warnings' => 0,
+ },
+ AUTHOR => 'Shlomi Fish <shlomif@iglu.org.il>',
+ ABSTRACT => 'Error/exception handling in an OO-ish way',
+ PL_FILES => {},
+);