summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Traud <pabstraud@compuserve.com>2021-11-03 11:10:29 +0100
committerAlexander Traud <pabstraud@compuserve.com>2021-11-11 08:40:58 +0000
commitc2a5891df792caf78c85c7ee10a525047487ba75 (patch)
tree9f858cb01c7d6c33e6753da3fcf387976ee3905e /CMakeLists.txt
parent3412cbdb92d91fc201bc441a446dc07839a794de (diff)
downloadevolution-data-server-c2a5891df792caf78c85c7ee10a525047487ba75.tar.gz
M!83 - Adjust .pc file not to expose used crypto library
Public headers of Evolution Data Server (and Camel) are not directly including headers of the crypto library NSS. The shared libraries already have links so NSS is at best only needed for static linking, but that must go into a the field called "private". The same applies for SQLite in Camel. Closes https://gitlab.gnome.org/GNOME/evolution-data-server/-/merge_requests/83
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6358035bf..a02f4bbc8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -941,7 +941,7 @@ set(ADDRESSBOOK_LDFLAGS ${ADDRESSBOOK_LDFLAGS} ${PHONENUMBER_LDFLAGS})
set(CALENDAR_CFLAGS ${CALENDAR_CFLAGS} -DLIBICAL_GLIB_UNSTABLE_API=1)
pkg_check_modules(CAMEL REQUIRED gio-2.0 gmodule-2.0 ${mozilla_nss} ${mozilla_nspr} sqlite3>=${sqlite_minimum_version})
-set(CAMEL_CFLAGS ${CAMEL_CFLAGS} ${KRB5_CFLAGS} ${MANUAL_NSS_CFLAGS} ${MANUAL_NSPR_CFLAGS} ${ICU_CFLAGS})
+set(CAMEL_CFLAGS ${CAMEL_CFLAGS} ${KRB5_CFLAGS} ${MANUAL_NSS_INCLUDES} ${MANUAL_NSPR_INCLUDES} ${ICU_CFLAGS})
set(CAMEL_LDFLAGS ${CAMEL_LDFLAGS} -lz ${KRB5_LDFLAGS} ${MANUAL_NSS_LIBS} ${MANUAL_NSPR_LIBS} ${ICU_LDFLAGS})
if(NOT (MANUAL_NSPR_INCLUDES STREQUAL ""))