summaryrefslogtreecommitdiff
path: root/test/configure.ac
diff options
context:
space:
mode:
authorJeremy Harris <jgh146exb@wizmail.org>2013-11-20 14:19:37 +0000
committerJeremy Harris <jgh146exb@wizmail.org>2013-11-20 14:36:19 +0000
commita4ca1b01d4376f9b9ca7e06acf4eb7d164a38d2b (patch)
treec541edf4bbd62fd4953d1cfd06349c54e99b4e20 /test/configure.ac
parent5428a9463ae1080029a84a1b33e4a8a6915c5f28 (diff)
downloadexim4-a4ca1b01d4376f9b9ca7e06acf4eb7d164a38d2b.tar.gz
Fix testsuite build on Solaris
As of s11, Solaris & derivatives need libsocket and libnsl. Ensure they are searched for by autoconfig. This seems to be successfully ignored on Linux. Credit to Dave Edmondson (dme@dme.org) for the fix.
Diffstat (limited to 'test/configure.ac')
-rw-r--r--test/configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/test/configure.ac b/test/configure.ac
index 83f1aa05d..a38b5b0ae 100644
--- a/test/configure.ac
+++ b/test/configure.ac
@@ -48,6 +48,11 @@ case $host_os in
;;
esac
+dnl Solaris requires additional libraries for networking functions.
+
+AC_SEARCH_LIBS([inet_addr], [nsl])
+AC_SEARCH_LIBS([connect], [socket])
+
dnl "Export" these variables
AC_SUBST(BIND_8_COMPAT)
@@ -55,6 +60,7 @@ AC_SUBST(CLIENT_SSL)
AC_SUBST(CLIENT_GNUTLS)
AC_SUBST(LOADED)
AC_SUBST(LOADED_OPT)
+AC_SUBST(LIBS)
dnl This must be last; it determines what files are written