summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorCyril Jaquier <cyril.jaquier@fail2ban.org>2007-01-04 12:58:21 +0000
committerCyril Jaquier <cyril.jaquier@fail2ban.org>2007-01-04 12:58:21 +0000
commitab3d2d1b9adf8909c26f28f7b672cd5e6fec3c9a (patch)
tree4f46882ca7d29521c39f1f2e662a5d8dbb1dbfab /setup.py
parent44d75eb54f3cd9f76a13f387691a880a37fec1bd (diff)
downloadfail2ban-ab3d2d1b9adf8909c26f28f7b672cd5e6fec3c9a.tar.gz
- Now Fail2ban goes in /usr/share/fail2ban instead of /usr/lib/fail2ban. This is more compliant with FHS. Thanks to Axel Thimm and Yaroslav Halchenko
git-svn-id: https://fail2ban.svn.sourceforge.net/svnroot/fail2ban/trunk@511 a942ae1a-1317-0410-a47c-b1dcaea8d605
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py9
1 files changed, 8 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 9ad1ece5..12da08f3 100755
--- a/setup.py
+++ b/setup.py
@@ -28,7 +28,7 @@ __license__ = "GPL"
from distutils.core import setup
from common.version import version
-from os.path import isfile, join
+from os.path import isfile, join, isdir
from sys import argv
from glob import glob
@@ -113,6 +113,13 @@ if obsoleteFiles:
print "\t" + f
print
+if isdir("/usr/lib/fail2ban"):
+ print
+ print "Fail2ban is not installed under /usr/lib anymore. The new " \
+ "location is under /usr/share. Please remove the directory " \
+ "/usr/lib/fail2ban and everything under this directory."
+ print
+
# Update config file
if argv[1] == "install":
print