summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorCyril Jaquier <cyril.jaquier@fail2ban.org>2006-06-26 20:05:00 +0000
committerCyril Jaquier <cyril.jaquier@fail2ban.org>2006-06-26 20:05:00 +0000
commitea1948eff40953b4590858698ced9f6b4c3733f8 (patch)
treee667d2906e70b34fe233c3409cb9052e4a77fe6a /setup.py
parent97aa913e243eacb8b93610d4ef6954d89c01a5eb (diff)
downloadfail2ban-ea1948eff40953b4590858698ced9f6b4c3733f8.tar.gz
- Initial commit of the new development release 0.7
git-svn-id: https://fail2ban.svn.sourceforge.net/svnroot/fail2ban/trunk@249 a942ae1a-1317-0410-a47c-b1dcaea8d605
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py82
1 files changed, 0 insertions, 82 deletions
diff --git a/setup.py b/setup.py
deleted file mode 100755
index 99b7f024..00000000
--- a/setup.py
+++ /dev/null
@@ -1,82 +0,0 @@
-#!/usr/bin/env python
-
-# This file is part of Fail2Ban.
-#
-# Fail2Ban is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2 of the License, or
-# (at your option) any later version.
-#
-# Fail2Ban is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with Fail2Ban; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-
-# Author: Cyril Jaquier
-#
-# $Revision$
-
-__author__ = "Cyril Jaquier"
-__version__ = "$Revision$"
-__date__ = "$Date$"
-__copyright__ = "Copyright (c) 2004 Cyril Jaquier"
-__license__ = "GPL"
-
-from distutils.core import setup
-from version import version
-from os.path import isfile, join
-from sys import exit, argv
-
-longdesc = '''
-Fail2Ban scans log files like /var/log/pwdfail or
-/var/log/apache/error_log and bans IP that makes
-too many password failures. It updates firewall rules
-to reject the IP address or executes user defined
-commands.'''
-
-setup(
- name = "fail2ban",
- version = version,
- description = "Ban IPs that make too many password failure",
- long_description = longdesc,
- author = "Cyril Jaquier",
- author_email = "lostcontrol@users.sourceforge.net",
- url = "http://fail2ban.sourceforge.net",
- license = "GPL",
- platforms = "Posix",
- scripts = ['fail2ban'],
- py_modules = ['fail2ban', 'version'],
- packages = ['firewall', 'logreader', 'confreader', 'utils']
-)
-
-# Do some checks after installation
-# Search for obsolete files.
-obsoleteFiles = []
-elements = {"/usr/bin/": ["fail2ban.py"],
- "/usr/lib/fail2ban/firewall/": ["iptables.py", "ipfwadm.py",
- "ipfw.py"]}
-for dir in elements:
- for f in elements[dir]:
- path = join(dir, f)
- if isfile(path):
- obsoleteFiles.append(path)
-if obsoleteFiles:
- print
- print "Obsolete files from previous Fail2Ban versions were found on " \
- "your system."
- print "Please delete them:"
- print
- for f in obsoleteFiles:
- print "\t" + f
- print
-
-# Update config file
-if argv[1] == "install":
- print
- print "Please do not forget to update your configuration file."
- print "Use config/fail2ban.conf.* as example."
- print