summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorSteven Hiscocks <steven@hiscocks.me.uk>2013-04-21 00:58:22 +0100
committerSteven Hiscocks <steven@hiscocks.me.uk>2013-04-21 00:58:22 +0100
commitf07a92f0f72f17092f7f03128dfaae219a316b52 (patch)
tree9d4e542508d0fa364329e4dcf74e0c9c9452f82c /setup.py
parent55810a3c30a745d5b099b40c42d0446b492ea995 (diff)
downloadfail2ban-f07a92f0f72f17092f7f03128dfaae219a316b52.tar.gz
RF: setup.py now imports version number again
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py8
1 files changed, 7 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 4b6e304e..6202fde7 100755
--- a/setup.py
+++ b/setup.py
@@ -75,9 +75,15 @@ if setuptools:
else:
setup_extra = {}
+# Get version number, avoiding importing fail2ban.
+# This is due to tests not functioning for python3 as 2to3 takes place later
+f = open("fail2ban/version.py")
+exec(f.read())
+f.close()
+
setup(
name = "fail2ban",
- version = "0.9.0a",
+ version = version,
description = "Ban IPs that make too many password failures",
long_description = longdesc,
author = "Cyril Jaquier",