summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorSteven Hiscocks <steven@hiscocks.me.uk>2013-04-13 16:54:22 +0100
committerSteven Hiscocks <steven@hiscocks.me.uk>2013-04-13 16:54:22 +0100
commitfa0f8f9e6df92702412376d84be745079db800f8 (patch)
tree391a03bb171edba396c203a1b8800becd2cae2f3 /setup.py
parenta33bf5baca961a2b13d330fb905de11802fbc50b (diff)
parent5aef036f543d516114760a8e5931a41d057814b0 (diff)
downloadfail2ban-fa0f8f9e6df92702412376d84be745079db800f8.tar.gz
Merge branch '0.9' into py3
Conflicts: .travis.yml MANIFEST bin/fail2ban-regex fail2ban/server/filter.py fail2ban/tests/servertestcase.py setup.py
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py23
1 files changed, 15 insertions, 8 deletions
diff --git a/setup.py b/setup.py
index 8aca6852..38392406 100755
--- a/setup.py
+++ b/setup.py
@@ -32,11 +32,12 @@ except ImportError:
# python 2.x
from distutils.command.build_py import build_py
from distutils.command.build_scripts import build_scripts
-from common.version import version
from os.path import isfile, join, isdir
import sys
from glob import glob
+from fail2ban.version import version
+
longdesc = '''
Fail2Ban scans log files like /var/log/pwdfail or
/var/log/apache/error_log and bans IP that makes
@@ -47,7 +48,7 @@ commands.'''
setup(
name = "fail2ban",
version = version,
- description = "Ban IPs that make too many password failure",
+ description = "Ban IPs that make too many password failures",
long_description = longdesc,
author = "Cyril Jaquier",
author_email = "cyril.jaquier@fail2ban.org",
@@ -56,15 +57,21 @@ setup(
platforms = "Posix",
cmdclass = {'build_py': build_py, 'build_scripts': build_scripts},
scripts = [
- 'fail2ban-client',
- 'fail2ban-server',
- 'fail2ban-regex'
+ 'bin/fail2ban-client',
+ 'bin/fail2ban-server',
+ 'bin/fail2ban-regex',
+ 'bin/fail2ban-testcases',
],
packages = [
- 'common',
- 'client',
- 'server'
+ 'fail2ban',
+ 'fail2ban.client',
+ 'fail2ban.server',
+ 'fail2ban.tests',
],
+ package_data = {
+ 'fail2ban.tests':
+ ['files/*.log', 'files/filter.d/*.conf'],
+ },
data_files = [
('/etc/fail2ban',
glob("config/*.conf")