summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorOlivier Crête <olivier.crete@collabora.co.uk>2007-10-29 18:59:27 -0400
committerOlivier Crête <olivier.crete@collabora.co.uk>2007-10-29 18:59:27 -0400
commit13f5110a0bd9a7d53e8d0d47b50f742176183739 (patch)
tree0fc1563d14103c3dbe74deb10f996f6e7276d13c /Makefile.am
parenta2a52b77ccc164ab897604b21e747bb5d915d00c (diff)
downloadfarstream-13f5110a0bd9a7d53e8d0d47b50f742176183739.tar.gz
Add more stuff to make the base unit test framework
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 17 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 4db12c80..6a1e1f44 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,19 +4,21 @@ SUBDIRS_EXT =
SUBDIRS = \
gst-libs \
- gst $(SUBDIRS_EXT) \
+ gst $(SUBDIRS_EXT) \
+ tests \
docs
#
-# tests \
+
# docs \
# pkgconfig
DIST_SUBDIRS = \
gst-libs \
- gst $(SUBDIRS_EXT) \
+ gst $(SUBDIRS_EXT) \
+ tests \
docs
#
-# tests \
+
# docs \
# pkgconfig
@@ -25,3 +27,14 @@ EXTRA_DIST = \
ChangeLog autogen.sh
ACLOCAL_AMFLAGS = -I common/m4
+
+check-valgrind:
+ cd tests/check && make check-valgrind
+
+if HAVE_GST_CHECK
+check-torture:
+ cd tests/check && make torture
+else
+check-torture:
+ true
+endif