summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSjoerd Simons <sjoerd@luon.net>2012-08-26 19:15:33 +0200
committerSjoerd Simons <sjoerd@luon.net>2012-09-13 00:09:57 +0200
commit528caf919d92d6a4f501c161f863fccccd851462 (patch)
treec43a888b037c0f662426e476df705771745719de /Makefile.am
parent129176598afd1d760ef5d7864276fc681d40abfd (diff)
downloadfarstream-528caf919d92d6a4f501c161f863fccccd851462.tar.gz
Add uninstalled pc file
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 10 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index f0f81b8f..f81f6885 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -43,14 +43,21 @@ check-torture:
true
endif
-pcverfiles = farstream-@FS_APIVERSION@.pc
-pcinfiles = farstream.pc.in
+pcverfiles = farstream-@FS_APIVERSION@.pc \
+ farstream-@FS_APIVERSION@-uninstalled.pc
+pcinfiles = farstream.pc.in \
+ farstream-uninstalled.pc.in
%-@FS_APIVERSION@.pc: %.pc
cp $< $@
+%-@FS_APIVERSION@-uninstalled.pc: %-uninstalled.pc
+ cp $< $@
+
pkgconfigdir = $(libdir)/pkgconfig
-pkgconfig_DATA = $(pcverfiles)
+pkgconfig_DATA = farstream-@FS_APIVERSION@.pc
+
+noinst_DATA = farstream-@FS_APIVERSION@-uninstalled.pc
CLEANFILES = $(pcverfiles)