summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorOlivier CrĂȘte <olivier.crete@collabora.co.uk>2008-03-08 13:44:01 -0500
committerOlivier CrĂȘte <olivier.crete@collabora.co.uk>2008-03-08 13:44:01 -0500
commitce2488eb2afac6bdd68503cd70bd84842b701401 (patch)
tree3a80b181ab1ecd3a2f13c07612c343d7620c9246 /Makefile.am
parent573ff93c8df3d617a8083c95bacdadeda48e50d9 (diff)
downloadfarstream-ce2488eb2afac6bdd68503cd70bd84842b701401.tar.gz
Add pkgconfig file
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 16 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 84fe3aff..88a0e814 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -25,7 +25,8 @@ DIST_SUBDIRS = \
# pkgconfig
EXTRA_DIST = \
- AUTHORS COPYING NEWS README ChangeLog autogen.sh
+ AUTHORS COPYING NEWS README ChangeLog autogen.sh \
+ $(pcinfiles)
ACLOCAL_AMFLAGS = -I common/m4
@@ -40,6 +41,19 @@ check-torture:
true
endif
+pcverfiles = farsight2-@GST_MAJORMINOR@.pc
+pcinfiles = farsight2.pc.in
+
+%-@GST_MAJORMINOR@.pc: %.pc
+ cp $< $@
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = $(pcverfiles)
+
+CLEANFILES = $(pcverfiles)
+
+DISTCLEANFILES = $(pcinfiles:.in=)
+
dist-hook:
chmod u+w ${distdir}/ChangeLog
- if test -d .git; then git log >${distdir}/ChangeLog; fi
+ if test -d .git; then git log >${distdir}/Chght2.pc.insngeLog; fi