summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNicolas Dufresne <nicolas.dufresne@collabora.com>2014-10-30 17:42:05 -0400
committerOlivier CrĂȘte <olivier.crete@collabora.com>2015-02-25 16:43:45 -0500
commitadb4765979f627dfce44590b243cd74af086da9a (patch)
tree9794a34b6eec020d9b3f9d586f3a83a9d48d55ef /configure.ac
parent98235c97645ff81cac4078b97d8f30d06eea1fff (diff)
downloadfarstream-adb4765979f627dfce44590b243cd74af086da9a.tar.gz
Enable building static GStreamer plugins
https://bugs.freedesktop.org/show_bug.cgi?id=89287
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 24 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e8580bab..ffb9db6c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -342,7 +342,7 @@ AC_SUBST(FS_PLUGIN_LDFLAGS)
dnl this really should only contain flags, not libs - they get added before
dnl whatevertarget_LIBS and -L flags here affect the rest of the linking
-GST_PLUGIN_LDFLAGS="-module -avoid-version -export-symbols-regex '^[_]*gst_plugin_desc\$\$' $FS_ALL_LDFLAGS"
+GST_PLUGIN_LDFLAGS="-module -avoid-version -export-symbols-regex '^[_]*gst_plugin_.*' $FS_ALL_LDFLAGS"
AC_SUBST(GST_PLUGIN_LDFLAGS)
AC_ARG_ENABLE([gupnp],
@@ -368,6 +368,29 @@ if test "x$HAVE_GUPNP" = "xyes"; then
AC_DEFINE(HAVE_GUPNP,,[Have the GUPnP IGD library])
fi
+dnl build static plugins or not
+AC_MSG_CHECKING([whether to build static plugins or not])
+AC_ARG_ENABLE(
+ static-plugins,
+ AC_HELP_STRING(
+ [--enable-static-plugins],
+ [build static plugins @<:@default=no@:>@]),
+ [AS_CASE(
+ [$enableval], [no], [], [yes], [],
+ [AC_MSG_ERROR([bad value "$enableval" for --enable-static-plugins])])],
+ [enable_static_plugins=no])
+AC_MSG_RESULT([$enable_static_plugins])
+if test "x$enable_static_plugins" = xyes; then
+ AS_IF([test x$enable_static = xno], [AC_MSG_ERROR([--enable-static-plugins requires --enable-static to work])])
+ AC_DEFINE(GST_PLUGIN_BUILD_STATIC, 1,
+ [Define if static plugins should be built])
+ PLUGIN_LIBTOOLFLAGS=""
+else
+ PLUGIN_LIBTOOLFLAGS="--tag=disable-static"
+fi
+AC_SUBST(PLUGIN_LIBTOOLFLAGS)
+AM_CONDITIONAL(GST_PLUGIN_BUILD_STATIC, test "x$enable_static_plugins" = "xyes")
+
dnl *** output files ***
AC_CONFIG_FILES(