summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorOlivier CrĂȘte <olivier.crete@collabora.co.uk>2008-09-15 17:19:27 -0400
committerOlivier CrĂȘte <olivier.crete@collabora.co.uk>2008-09-15 17:19:27 -0400
commitff4513563e288604deea72dbeb9cf8e6ff3e9eb5 (patch)
tree49232e878fc2bdffb8adf5f255982a520bc1bde2 /tests/Makefile.am
parentc75e2637e89e8109ca38b0746ce345a1d384daa5 (diff)
downloadfarstream-ff4513563e288604deea72dbeb9cf8e6ff3e9eb5.tar.gz
Don't build upnp tests if not enabled
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am12
1 files changed, 8 insertions, 4 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index ca83c4d3..90d87e4b 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,9 +1,13 @@
-if HAVE_GST_CHECK
-SUBDIRS_CHECK = check
-else
SUBDIRS_CHECK =
+
+if HAVE_GST_CHECK
+SUBDIRS_CHECK += check
+endif
+
+if HAVE_GUPNP
+SUBDIRS_CHECK += upnp
endif
-SUBDIRS = $(SUBDIRS_CHECK) rtp gui commandline upnp
+SUBDIRS = $(SUBDIRS_CHECK) rtp gui commandline
DIST_SUBDIRS = check rtp gui commandline upnp