summaryrefslogtreecommitdiff
path: root/libavformat/rtp.h
Commit message (Collapse)AuthorAgeFilesLines
* lavf/sdp: add const qualifiers where appropriateAnton Khirnov2021-12-171-2/+2
| | | | Declares that these structs are read-only for this code.
* Remove/replace some unnecessary avcodec.h inclusionsAndreas Rheinhardt2021-07-221-2/+4
| | | | | | | Also remove other unnecessary headers and include headers directly while at it. Signed-off-by: Andreas Rheinhardt <andreas.rheinhardt@outlook.com>
* Merge commit '9200514ad8717c63f82101dc394f4378854325bf'Derek Buitenhuis2016-04-101-4/+4
|\ | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | * commit '9200514ad8717c63f82101dc394f4378854325bf': lavf: replace AVStream.codec with AVStream.codecpar This has been a HUGE effort from: - Derek Buitenhuis <derek.buitenhuis@gmail.com> - Hendrik Leppkes <h.leppkes@gmail.com> - wm4 <nfxjfg@googlemail.com> - Clément Bœsch <clement@stupeflix.com> - James Almer <jamrial@gmail.com> - Michael Niedermayer <michael@niedermayer.cc> - Rostislav Pehlivanov <atomnuker@gmail.com> Merged-by: Derek Buitenhuis <derek.buitenhuis@gmail.com>
| * lavf: replace AVStream.codec with AVStream.codecparAnton Khirnov2016-02-231-4/+4
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Currently, AVStream contains an embedded AVCodecContext instance, which is used by demuxers to export stream parameters to the caller and by muxers to receive stream parameters from the caller. It is also used internally as the codec context that is passed to parsers. In addition, it is also widely used by the callers as the decoding (when demuxer) or encoding (when muxing) context, though this has been officially discouraged since Libav 11. There are multiple important problems with this approach: - the fields in AVCodecContext are in general one of * stream parameters * codec options * codec state However, it's not clear which ones are which. It is consequently unclear which fields are a demuxer allowed to set or a muxer allowed to read. This leads to erratic behaviour depending on whether decoding or encoding is being performed or not (and whether it uses the AVStream embedded codec context). - various synchronization issues arising from the fact that the same context is used by several different APIs (muxers/demuxers, parsers, bitstream filters and encoders/decoders) simultaneously, with there being no clear rules for who can modify what and the different processes being typically delayed with respect to each other. - avformat_find_stream_info() making it necessary to support opening and closing a single codec context multiple times, thus complicating the semantics of freeing various allocated objects in the codec context. Those problems are resolved by replacing the AVStream embedded codec context with a newly added AVCodecParameters instance, which stores only the stream parameters exported by the demuxers or read by the muxers.
* | Merge commit '2e814d0329aded98c811d0502839618f08642685'Michael Niedermayer2013-08-011-0/+3
|\ \ | |/ | | | | | | | | | | * commit '2e814d0329aded98c811d0502839618f08642685': rtpenc: Simplify code by introducing a macro for rescaling NTP timestamps Merged-by: Michael Niedermayer <michaelni@gmx.at>
| * rtpenc: Simplify code by introducing a macro for rescaling NTP timestampsMartin Storsjö2013-07-311-0/+3
| | | | | | | | Signed-off-by: Martin Storsjö <martin@martin.st>
* | Merge remote-tracking branch 'qatar/master'Michael Niedermayer2012-11-151-2/+7
|\ \ | |/ | | | | | | | | | | | | | | | | | | * qatar/master: bgmc: Fix av_malloc checks in ff_bgmc_init() rtp: set the payload type as stream id Conflicts: libavformat/rtpenc_chain.c Merged-by: Michael Niedermayer <michaelni@gmx.at>
| * rtp: set the payload type as stream idLuca Barbato2012-11-141-2/+7
| | | | | | | | | | | | | | Support multiple video/audio streams with different format in the same session. Signed-off-by: Luca Barbato <lu_zero@gentoo.org>
* | Merge commit '1cd432e167b1a80853760c89a33606e2b5f229c2'Michael Niedermayer2012-10-191-2/+13
|\ \ | |/ | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | * commit '1cd432e167b1a80853760c89a33606e2b5f229c2': configure: fix libcdio check rtsp: Allow setting the reordering buffer size via an AVOption rtsp: Vertically align a constant definition rtp: Update the check for distinguishing between RTP and RTCP aac: fix build with hardcoded tables fate: dependencies for screen codec tests riff: Move functions around to be covered by appropriate #ifdefs Conflicts: configure tests/fate/screen.mak Merged-by: Michael Niedermayer <michaelni@gmx.at>
| * rtp: Update the check for distinguishing between RTP and RTCPMartin Storsjö2012-10-181-2/+13
| | | | | | | | | | | | | | Also add enums for more RTCP packet types, according to the IANA list of registered types. Signed-off-by: Martin Storsjö <martin@martin.st>
* | Merge commit '36ef5369ee9b336febc2c270f8718cec4476cb85'Michael Niedermayer2012-08-071-2/+2
|\ \ | |/ | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | * commit '36ef5369ee9b336febc2c270f8718cec4476cb85': Replace all CODEC_ID_* with AV_CODEC_ID_* lavc: add AV prefix to codec ids. Conflicts: doc/APIchanges doc/examples/decoding_encoding.c doc/examples/muxing.c ffmpeg.c ffprobe.c ffserver.c libavcodec/8svx.c libavcodec/avcodec.h libavcodec/dnxhd_parser.c libavcodec/dvdsubdec.c libavcodec/error_resilience.c libavcodec/h263dec.c libavcodec/libvorbisenc.c libavcodec/mjpeg_parser.c libavcodec/mjpegenc.c libavcodec/mpeg12.c libavcodec/mpeg4videodec.c libavcodec/mpegvideo.c libavcodec/mpegvideo_enc.c libavcodec/pcm.c libavcodec/r210dec.c libavcodec/utils.c libavcodec/v210dec.c libavcodec/version.h libavdevice/alsa-audio-dec.c libavdevice/bktr.c libavdevice/v4l2.c libavformat/asfdec.c libavformat/asfenc.c libavformat/avformat.h libavformat/avidec.c libavformat/caf.c libavformat/electronicarts.c libavformat/flacdec.c libavformat/flvdec.c libavformat/flvenc.c libavformat/framecrcenc.c libavformat/img2.c libavformat/img2dec.c libavformat/img2enc.c libavformat/ipmovie.c libavformat/isom.c libavformat/matroska.c libavformat/matroskadec.c libavformat/matroskaenc.c libavformat/mov.c libavformat/movenc.c libavformat/mp3dec.c libavformat/mpeg.c libavformat/mpegts.c libavformat/mxf.c libavformat/mxfdec.c libavformat/mxfenc.c libavformat/nsvdec.c libavformat/nut.c libavformat/oggenc.c libavformat/pmpdec.c libavformat/rawdec.c libavformat/rawenc.c libavformat/riff.c libavformat/sdp.c libavformat/utils.c libavformat/vocenc.c libavformat/wtv.c libavformat/xmv.c Merged-by: Michael Niedermayer <michaelni@gmx.at>
| * Replace all CODEC_ID_* with AV_CODEC_ID_*Anton Khirnov2012-08-071-2/+2
| |
* | Merge remote-tracking branch 'qatar/master'Michael Niedermayer2012-07-041-1/+1
|\ \ | |/ | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | * qatar/master: cosmetics: Consistently use C-style comments with multiple inclusion guards anm: fix a few Doxygen comments misc typo and wording fixes attributes: add av_noreturn attributes: drop pointless define guards configure: do not disable av_always_inline with --enable-small flvdec: initial stream switch support avplay: fix write on freed memory for rawvideo snow: remove a VLA used for edge emulation x86: lavfi: fix gradfun/yadif build with mmx/sse disabled snow: remove the runs[] VLA. snow: Check mallocs at init flacdec: remove redundant setting of avctx->sample_fmt Conflicts: ffplay.c libavcodec/h264.c libavcodec/snow.c libavcodec/snow.h libavcodec/snowdec.c libavcodec/snowenc.c libavformat/flvdec.c libavutil/attributes.h tools/patcheck Merged-by: Michael Niedermayer <michaelni@gmx.at>
| * misc typo and wording fixesDiego Biurrun2012-07-031-1/+1
| |
* | Merge remote-tracking branch 'qatar/master'Michael Niedermayer2012-02-171-0/+2
|\ \ | |/ | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | * qatar/master: shorten: Use separate pointers for the allocated memory for decoded samples. atrac3: Fix crash in tonal component decoding. ws_snd1: Fix wrong samples counts. movenc: Don't set a default sample duration when creating ismv rtp: Factorize the check for distinguishing RTCP packets from RTP golomb: avoid infinite loop on all-zero input (or end of buffer). bethsoftvid: synchronize video timestamps with audio sample rate bethsoftvid: add audio stream only after getting the first audio packet bethsoftvid: Set video packet duration instead of accumulating pts. bethsoftvid: set packet key frame flag for audio and I-frame video packets. bethsoftvid: fix read_packet() return codes. bethsoftvid: pass palette in side data instead of in a separate packet. sdp: Ignore RTCP packets when autodetecting RTP streams proresenc: initialise 'sign' variable mpegaudio: replace memcpy by SIMD code vc1: prevent using last_frame as a reference for I/P first frame. Conflicts: libavcodec/atrac3.c libavcodec/golomb.h libavcodec/shorten.c libavcodec/ws-snd1.c tests/ref/fate/bethsoft-vid Merged-by: Michael Niedermayer <michaelni@gmx.at>
| * rtp: Factorize the check for distinguishing RTCP packets from RTPMartin Storsjö2012-02-161-0/+2
| | | | | | | | | | | | The binary doesn't change after this patch. Signed-off-by: Martin Storsjö <martin@martin.st>
* | Merge remote-tracking branch 'qatar/master'Michael Niedermayer2011-12-121-1/+1
|\ \ | |/ | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | * qatar/master: x86: cabac: replace explicit memory references with "m" operands avplay: don't request a stereo downmix wmapro: use av_float2int() lavc: avoid invalid memcpy() in avcodec_default_release_buffer() lavu: replace int/float punning functions lavfi: install libavfilter/vsrc_buffer.h Remove extraneous semicolons sdp: Restore the original mp4 format h264 extradata if converted rtpenc: Add support for mp4 format h264 rtpenc: Simplify code by introducing a separate end pointer movenc: Use the actual converted sample for RTP hinting Fix a bunch of common typos. Conflicts: doc/developer.texi doc/eval.texi doc/filters.texi doc/protocols.texi ffmpeg.c ffplay.c libavcodec/mpegvideo.h libavcodec/x86/cabac.h libavfilter/Makefile libavformat/avformat.h libavformat/cafdec.c libavformat/flvdec.c libavformat/flvenc.c libavformat/gxfenc.c libavformat/img2.c libavformat/movenc.c libavformat/mpegts.c libavformat/rtpenc_h264.c libavformat/utils.c libavformat/wtv.c Merged-by: Michael Niedermayer <michaelni@gmx.at>
| * Fix a bunch of common typos.Diego Biurrun2011-12-111-1/+1
| |
* | Merge remote-tracking branch 'qatar/master'Michael Niedermayer2011-09-271-5/+5
|\ \ | |/ | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | * qatar/master: (21 commits) fate: allow testing with libavfilter disabled x86: XOP/FMA4 CPU detection support ws_snd: misc cosmetic clean-ups ws_snd: remove the 2-bit ADPCM table and just subtract 2 instead. ws_snd: use memcpy() and memset() instead of loops ws_snd: use samples pointer for loop termination instead of a separate iterator variable. ws_snd: make sure number of channels is 1 ws_snd: add some checks to prevent buffer overread or overwrite. ws_snd: decode to AV_SAMPLE_FMT_U8 instead of S16. flacdec: fix buffer size checking in get_metadata_size() rtp: Simplify ff_rtp_get_payload_type rtpenc: Add a payload type private option rtp: Correct ff_rtp_get_payload_type documentation avconv: replace all fprintf() by av_log(). avconv: change av_log verbosity from ERROR to FATAL for fatal errors. cmdutils: replace fprintf() by av_log() avtools: parse loglevel before all the other options. oggdec: add support for Xiph's CELT codec sol: return error if av_get_packet() fails. cosmetics: reindent and pretty-print ... Conflicts: avconv.c cmdutils.c libavcodec/avcodec.h libavcodec/version.h libavformat/oggparsecelt.c libavformat/utils.c libavutil/avutil.h Merged-by: Michael Niedermayer <michaelni@gmx.at>
| * rtpenc: Add a payload type private optionRafaël Carré2011-09-261-2/+4
| | | | | | | | | | | | | | | | Specifying the payload type is useful when the type number has already been negotiated before creating the stream, for example in SIP protocol. Signed-off-by: Martin Storsjö <martin@martin.st>
| * rtp: Correct ff_rtp_get_payload_type documentationRafaël Carré2011-09-261-3/+1
| | | | | | | | | | | | Since 0c378ea1f, it can't fail anymore. Signed-off-by: Martin Storsjö <martin@martin.st>
| * Replace FFmpeg with Libav in licence headersMans Rullgard2011-03-191-4/+4
|/ | | | Signed-off-by: Mans Rullgard <mans@mansr.com>
* rtp: Replace hardcoded RTCP packet types with definesJosh Allmann2010-08-251-0/+9
| | | | | | Patch by Josh Allmann, joshua dot allmann at gmail Originally committed as revision 24912 to svn://svn.ffmpeg.org/ffmpeg/trunk
* rtpenc_xiph: Set the ident value via a defineMartin Storsjö2010-08-091-0/+6
| | | | Originally committed as revision 24749 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Define AVMediaType enum, and use it instead of enum CodecType, whichStefano Sabatini2010-03-301-1/+1
| | | | | | is deprecated and will be dropped at the next major bump. Originally committed as revision 22735 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Document ff_rtp_codec_id()Luca Abeni2009-02-281-0/+9
| | | | Originally committed as revision 17666 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Fix typo in a commentLuca Abeni2009-02-281-1/+1
| | | | Originally committed as revision 17664 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Document ff_rtp_enc_name()Luca Abeni2009-02-281-0/+10
| | | | Originally committed as revision 17663 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Document ff_rtp_get_codec_info()Luca Abeni2009-02-281-0/+12
| | | | Originally committed as revision 17661 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Remame rtp_get_codec_info() to ff_rtp_get_codec_info(), as it is notLuca Abeni2009-02-171-1/+1
| | | | | | a static function Originally committed as revision 17390 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Move to rtp.h the prototypes of all the functions defined in rtp.cLuca Abeni2009-02-171-0/+4
| | | | Originally committed as revision 17389 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Document ff_rtp_get_payload_type()Luca Abeni2009-02-161-1/+8
| | | | Originally committed as revision 17365 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Rename rtp_get_payload_type() to ff_rtp_get_payload_type(), as it is notLuca Abeni2009-02-161-1/+1
| | | | | | a static function Originally committed as revision 17364 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Move RTP_MAX_PACKET_LENGTH to rtpdec.h: it is not used in the muxer anymoreLuca Abeni2009-02-061-2/+0
| | | | Originally committed as revision 17023 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Split rtp.h in rtp.h, rtpdec.h, and rtpenc.hLuca Abeni2009-02-061-161/+0
| | | | Originally committed as revision 17016 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Add "AVFormatContext *ctx" (that being the RTSP demuxer's) as first argumentRonald S. Bultje2009-02-061-1/+3
| | | | | | | | | | | | to the parse_packet() function pointer in RTPDynamicProtocolHandlers. This allows these functions to peek back and retrieve values from the demuxer's context (or RTSPState). The ASF/RTP payload parser will use this to be able to parse SDP values (which occur even before the payload ID is given), store them in the RTSPState and then retrieve them while parsing payload data. See "[PATCH] RTSP-MS 13/15: add RTSP demuxer AVFormatContext to parse_packet() function pointer (was: transport context)" mailinglist thread. Originally committed as revision 17015 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Introduce a new num_frames field in RTPDemuxContext so that rtp_aac.cLuca Abeni2009-02-051-0/+1
| | | | | | does not need to abuse read_buf_index Originally committed as revision 17004 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Merge rtp_internal.h in rtp.h, and remove rtp_internal.hLuca Abeni2009-01-271-0/+105
| | | | Originally committed as revision 16817 to svn://svn.ffmpeg.org/ffmpeg/trunk
* cosmetics: Remove pointless period after copyright statement non-sentences.Diego Biurrun2009-01-191-1/+1
| | | | Originally committed as revision 16684 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Rename rtp_payload_data_t to avoid clashes with the POSIX namespaceLuca Abeni2008-12-131-3/+3
| | | | Originally committed as revision 16115 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Remove useless typedefLuca Abeni2008-12-131-29/+28
| | | | Originally committed as revision 16114 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Remove unused typesLuca Abeni2008-12-131-25/+0
| | | | Originally committed as revision 16113 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Remove access into RTPDemuxContext in rtsp.c, which allows making it opaqueRonald S. Bultje2008-10-041-0/+5
| | | | | | | (and thus preparing for the introduction of RDTDemuxContext) in a next patch. See discussion in "RDT/Realmedia patches #2" thread on ML. Originally committed as revision 15542 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Globally rename the header inclusion guard names.Stefano Sabatini2008-08-311-3/+3
| | | | | | | | | Consistently apply this rule: the guard name is obtained from the filename by stripping the leading "lib", converting '/' and '.' to '_' and uppercasing the resulting name. Guard names in the root directory have to be prefixed by "FFMPEG_". Originally committed as revision 15120 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Revert r14497Michael Niedermayer2008-08-011-1/+0
| | | | | | | | | Log: Add missing header #includes. Policy violation (change not approved by maintainer) and while discussions where ongoing and no consensus has been reached. Originally committed as revision 14500 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Add missing header #includes.Diego Biurrun2008-08-011-0/+1
| | | | Originally committed as revision 14497 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Use full path for #includes from another directory.Diego Biurrun2008-05-091-1/+1
| | | | Originally committed as revision 13098 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Make AVRtpPayloadTypes static and constantDiego Pettenò2008-01-061-11/+0
| | | | | | Patch by Diego 'Flameeyes' Pettenò (flameeyes AT gmail DOT com) Originally committed as revision 11432 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Remove prototype for non-existent functionLuca Abeni2007-10-261-1/+0
| | | | Originally committed as revision 10862 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Add FFMPEG_ prefix to all multiple inclusion guards.Diego Biurrun2007-10-171-3/+3
| | | | Originally committed as revision 10765 to svn://svn.ffmpeg.org/ffmpeg/trunk