summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristos Zoulas <christos@zoulas.com>2009-05-18 18:31:02 +0000
committerChristos Zoulas <christos@zoulas.com>2009-05-18 18:31:02 +0000
commit6828809702c183835495ad2b34a9ad05c7aee052 (patch)
tree3bbd24c69df738f405af569520e0533be7c08cbb /configure.ac
parente234c2fdf4295a0ecf2bbf7d27b526fd387b9a43 (diff)
downloadfile-git-6828809702c183835495ad2b34a9ad05c7aee052.tar.gz
flip the polarity of the gcc test.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 5fc7b3cf..9da571d8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -130,15 +130,15 @@ else
-Wsign-compare -Wreturn-type -Wswitch -Wshadow \
-Wcast-qual -Wwrite-strings -Wextra -Wunused-parameter"
fi], [
-if test "$GCC" = no; then
- WARNINGS=
- AC_MSG_RESULT(no)
-else
+if test "$GCC" = yes; then
AC_MSG_RESULT(yes)
WARNINGS="-Wall -Wstrict-prototypes -Wmissing-prototypes -Wpointer-arith \
-Wmissing-declarations -Wredundant-decls -Wnested-externs \
-Wsign-compare -Wreturn-type -Wswitch -Wshadow \
-Wcast-qual -Wwrite-strings -Wextra -Wunused-parameter"
+else
+ WARNINGS=
+ AC_MSG_RESULT(no)
fi])
dnl Checks for functions