summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristos Zoulas <christos@zoulas.com>2009-02-24 21:53:13 +0000
committerChristos Zoulas <christos@zoulas.com>2009-02-24 21:53:13 +0000
commitbb84f4c93ee34d413167343a0023cb439944fbb8 (patch)
treefbc1d783b93a7909ca8acbd80f7ef54d97c37185 /configure.ac
parent862dd3b1f74c03010fd2358da2cfe7a5fb46a7ea (diff)
downloadfile-git-bb84f4c93ee34d413167343a0023cb439944fbb8.tar.gz
quote gcc.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 4a5561e3..912daf4c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -120,7 +120,7 @@ typedef long int64_t;
AC_MSG_CHECKING(for gcc compiler warnings)
AC_ARG_ENABLE(warnings,
[ --disable-warnings disable compiler warnings],
-[if test "${enableval}" = no -o $GCC = no; then
+[if test "${enableval}" = no -o "$GCC" = no; then
AC_MSG_RESULT(no)
WARNINGS=
else
@@ -130,7 +130,7 @@ else
-Wsign-compare -Wreturn-type -Wswitch -Wshadow \
-Wcast-qual -Wwrite-strings -Wextra -Wunused-parameter"
fi], [
-if test $GCC = no; then
+if test "$GCC" = no; then
WARNINGS=
AC_MSG_RESULT(no)
else