summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristos Zoulas <christos@zoulas.com>2013-02-18 15:40:59 +0000
committerChristos Zoulas <christos@zoulas.com>2013-02-18 15:40:59 +0000
commitd68a455e1a8d81bc7991c7ad0f07b24697b1ff6e (patch)
tree25b2db3a1c9c3592120a2ca12b57502a59d30b03 /configure.ac
parentfdf64bc282499cf01652702be9dd35e345d1ce0a (diff)
downloadfile-git-d68a455e1a8d81bc7991c7ad0f07b24697b1ff6e.tar.gz
- use pread
- add reading of section header names to determine if an ELF file is stripped (Jan Kaluza)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ac5d8c6c..0e0080a6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -140,7 +140,7 @@ dnl Checks for functions
AC_CHECK_FUNCS(strerror strndup strtoul mkstemp mkostemp utimes utime wcwidth strtof)
dnl Provide implementation of some required functions if necessary
-AC_REPLACE_FUNCS(getopt_long asprintf vasprintf strlcpy strlcat getline ctime_r asctime_r)
+AC_REPLACE_FUNCS(getopt_long asprintf vasprintf strlcpy strlcat getline ctime_r asctime_r pread)
dnl Checks for libraries
AC_CHECK_LIB(z,gzopen)