summaryrefslogtreecommitdiff
path: root/python/setup.py
diff options
context:
space:
mode:
authorLorry Tar Creator <lorry-tar-importer@lorry>2017-09-02 08:54:31 +0000
committerLorry Tar Creator <lorry-tar-importer@lorry>2017-09-02 08:54:31 +0000
commit10429269fbeb9442be4c5592b9111ccedbfefd0d (patch)
treeec492f5b26d71445da74668b4c967621e9ebc556 /python/setup.py
parent670c2bbcffe873a2b8589ed140c12e7923ef20c0 (diff)
downloadfile-10429269fbeb9442be4c5592b9111ccedbfefd0d.tar.gz
Diffstat (limited to 'python/setup.py')
-rw-r--r--python/setup.py32
1 files changed, 22 insertions, 10 deletions
diff --git a/python/setup.py b/python/setup.py
index 2c3b527..24ae182 100644
--- a/python/setup.py
+++ b/python/setup.py
@@ -1,10 +1,22 @@
-# Python distutils build script for magic extension
-from distutils.core import setup
-
-setup(name = 'Magic file extensions',
- version = '0.2',
- author = 'Reuben Thomas',
- author_email = 'rrt@sc3d.org',
- license = 'BSD',
- description = 'libmagic Python bindings',
- py_modules = ['magic'])
+# coding: utf-8
+
+from __future__ import unicode_literals
+
+from setuptools import setup
+
+
+setup(name='file-magic',
+ version='0.3.0',
+ author='Reuben Thomas, Álvaro Justen',
+ author_email='rrt@sc3d.org, alvarojusten@gmail.com',
+ url='https://github.com/file/file',
+ license='BSD',
+ description='(official) libmagic Python bindings',
+ py_modules=['magic'],
+ test_suite='tests',
+ classifiers = [
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: BSD License',
+ 'Natural Language :: English',
+ 'Topic :: Software Development :: Libraries :: Python Modules',
+ ])