summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorLorry Tar Creator <lorry-tar-importer@lorry>2017-09-02 08:54:31 +0000
committerLorry Tar Creator <lorry-tar-importer@lorry>2017-09-02 08:54:31 +0000
commit10429269fbeb9442be4c5592b9111ccedbfefd0d (patch)
treeec492f5b26d71445da74668b4c967621e9ebc556 /tests/Makefile.am
parent670c2bbcffe873a2b8589ed140c12e7923ef20c0 (diff)
downloadfile-10429269fbeb9442be4c5592b9111ccedbfefd0d.tar.gz
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index c2cb5ee..8bf4f27 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,16 +1,18 @@
check_PROGRAMS = test
test_LDADD = $(top_builddir)/src/libmagic.la
-test_CPPFLAGS = -I$(top_srcdir)/src
+test_CPPFLAGS = -I$(top_builddir)/src
EXTRA_DIST = \
escapevel.result \
escapevel.testfile \
gedcom.result \
gedcom.testfile \
+hddrawcopytool.result \
+hddrawcopytool.testfile \
issue311docx.result \
issue311docx.testfile
T = $(top_srcdir)/tests
check-local:
MAGIC=$(top_builddir)/magic/magic ./test
- for i in $T/*.testfile; do echo Running test: $$i; MAGIC=$(top_builddir)/magic/magic ./test $$i $${i%%.testfile}.result; done
+ set -e; for i in $T/*.testfile; do echo Running test: $$i; TZ=UTC MAGIC=$(top_builddir)/magic/magic ./test $$i $${i%%.testfile}.result; done