summaryrefslogtreecommitdiff
path: root/python/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'python/setup.py')
-rw-r--r--python/setup.py10
1 files changed, 10 insertions, 0 deletions
diff --git a/python/setup.py b/python/setup.py
new file mode 100644
index 0000000..2c3b527
--- /dev/null
+++ b/python/setup.py
@@ -0,0 +1,10 @@
+# Python distutils build script for magic extension
+from distutils.core import setup
+
+setup(name = 'Magic file extensions',
+ version = '0.2',
+ author = 'Reuben Thomas',
+ author_email = 'rrt@sc3d.org',
+ license = 'BSD',
+ description = 'libmagic Python bindings',
+ py_modules = ['magic'])