summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Youngman <jay@gnu.org>2013-03-31 20:25:49 +0100
committerJames Youngman <jay@gnu.org>2013-03-31 20:25:49 +0100
commit16e147b9909745dab72bfb7f839fb07af849ee3e (patch)
tree7b60eb84b169c8248c3a375829f77dc214eeb7dc /Makefile.am
parentfdaa57adba0f7016781aeab078c144e4ae1f7681 (diff)
downloadfindutils-16e147b9909745dab72bfb7f839fb07af849ee3e.tar.gz
Don't use reserved identifiers in macro names; fix other code smells.
* build-aux/src-sniff.py (checkers): Check for #define directives which use a macro name which is reserved. (MakefileRegexChecker): New class which performs regex checks on makefiles; this ensures that we don't check Makefile.in if we're going to check Makefile.am anyway. * lib/unused-result.h: Don't use a reserved identifier in the macro name defined as the #include guard. * locate/locatedb.h: Likewise. * Makefile.am (findutils-check-smells): Don't check gnulib code. * import-gnulib.sh (hack_gnulib_tool_output): Move the 'do' of a for loop onto the line following the 'for' (instead of the same line).
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 4f178c30..fa54bac4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -48,6 +48,8 @@ findutils-check-testfiles:
findutils-check-smells:
find $(srcdir) \( -path $(srcdir)/autom4te.cache -o \
-path $(srcdir)/gnulib -o \
+ -path $(srcdir)/gl -o \
+ -path $(srcdir)/tests -o \
-name .git -o \
\( -type d -name CVS \) \
\) -prune -o \