summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJames Youngman <jay@gnu.org>2016-01-24 23:15:57 +0000
committerJames Youngman <jay@gnu.org>2016-01-25 23:56:17 +0000
commit931fc967d17aea8cc851120c698fee6f1690b483 (patch)
treea905914b80c3ba37fe6aedcd467ec2b559e4c602 /configure.ac
parentf535461241e8f9c4738b435c6af892decb92d829 (diff)
downloadfindutils-931fc967d17aea8cc851120c698fee6f1690b483.tar.gz
updatedb: use the common definitions of the bug-report URL etc.
* locate/Makefile.am (updatedb): Substitute PACKAGE_BUGREPORT, PACKAGE_BUGREPORT_URL and PACKAGE_URL. We do this in the Makefile directly since updatedb.sh is not an output file generated directly by configure (instead, it's generated by the Makefile itself). * configure.ac (PACKAGE_BUGREPORT_URL): AC_DEFINE defines only a preprocessor macro. In order to get a similar effect for substituted output files, we need to use AC_SUBST. Hence introduce a shell variable $bugreport_url which we pass to both AC_SUBST and AC_DEFINE_UNQUOTED (replacing the previous call to AC_DEFINE). * locate/updatedb.sh (usage): Use PACKAGE_URL and PACKAGE_BUGREPORT_URL.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 13 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 0a60a266..528d4423 100644
--- a/configure.ac
+++ b/configure.ac
@@ -20,13 +20,23 @@ dnl Written by James Youngman.
dnl Process this file with autoconf to produce a configure script.
AC_INIT([GNU findutils], 4.7.0-git, [bug-findutils@gnu.org])
+
+dnl Set the bug-report URL
+dnl
dnl The call to AC_INIT causes AC_PACKAGE_BUGREPORT to be defined
dnl and we've used an email address. However, we would also like to
dnl specify at URL at which to report bugs (and in fact we prefer
dnl people to use that). Se we define that here, too.
-AC_DEFINE([PACKAGE_BUGREPORT_URL],
- ["https://savannah.gnu.org/bugs/?group=findutils"],
- [URL at which bugs should be reported])
+bugreport_url='https://savannah.gnu.org/bugs/?group=findutils'
+dnl Ensure that PACKAGE_BUGREPORT_URL shows up n config.h so that
+dnl it can be picked up by bugreport.c.
+AC_DEFINE_UNQUOTED([PACKAGE_BUGREPORT_URL], ["$bugreport_url"],
+ [URL at which bugs should be reported])
+dnl Also ensure that it is substituted in output files so that it
+dnl turns up in locate/Makefile so that we can generate the correct
+dnl content in the updatedb script.
+AC_SUBST([PACKAGE_BUGREPORT_URL],[$bugreport_url])
+
AC_CONFIG_AUX_DIR(build-aux)
AM_INIT_AUTOMAKE