summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorJames Youngman <jay@gnu.org>2011-05-30 00:34:18 +0100
committerJames Youngman <jay@gnu.org>2011-05-30 02:00:23 +0100
commitd09450a94c55b85a6ede44938b03d4968681c39a (patch)
treedb512514b206232f6a90781547fd66b88fe66993 /lib/Makefile.am
parentde53ac26074b94ec249e69f9850b999efae4f1d3 (diff)
downloadfindutils-d09450a94c55b85a6ede44938b03d4968681c39a.tar.gz
Manage gnulib as a git submodule.
* .gitmodules: New file; manage gnulib as a submodule. For future compatibility with the "bootstrap" script, keep the gnulib submodule in the gnulib directory (instead of the gnulib-git directory as before). This means we need to find a new directory for the output of gnulib-tool; we will use "gl" for that. * import-gnulib.sh (do_checkout): Replace with do_submodule. (do_submodule): initialise and configure the gnulib module. (main): call do_submodule instead of do_checkout. Don't call move_cvsdir, it's obsolete. (move_cvsdir): delete * Makefile.am (SUBDIRS): Rename gnulib to gl. (ACLOCAL_AMFLAGS): Likewise. (findutils-check-smells): Rename gnulib-git to gnulib. * .gitignore: Rename gnulib to gl.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 029037e5..21967311 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -30,8 +30,8 @@ DISTCLEANFILES =
MAINTAINERCLEANFILES =
-INCLUDES = -I../gnulib/lib -I$(top_srcdir)/gnulib/lib
-LDADD = ../gnulib/lib/libgnulib.a $(LIBINTL)
+INCLUDES = -I../gl/lib -I$(top_srcdir)/gl/lib
+LDADD = ../gl/lib/libgnulib.a $(LIBINTL)
libfind_a_SOURCES += nextelem.h printquoted.h listfile.h \
regextype.h dircallback.h safe-atoi.h