summaryrefslogtreecommitdiff
path: root/locate/Makefile.am
diff options
context:
space:
mode:
authorKevin Dalley <kevin@seti.org>2000-04-05 08:08:35 +0000
committerKevin Dalley <kevin@seti.org>2000-04-05 08:08:35 +0000
commit73caeaa281dd764b93ee7fae86098b70863c76a8 (patch)
tree403568a6caa76c0abd282a59f9d72708097ee2e3 /locate/Makefile.am
parentfa7296a66b0f468347c3aea81529240ec28704f8 (diff)
downloadfindutils-73caeaa281dd764b93ee7fae86098b70863c76a8.tar.gz
* locate/Makefile.am: create updatedb from updatedb.sh
Diffstat (limited to 'locate/Makefile.am')
-rw-r--r--locate/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/locate/Makefile.am b/locate/Makefile.am
index a5875a2d..e538b0e1 100644
--- a/locate/Makefile.am
+++ b/locate/Makefile.am
@@ -1,4 +1,5 @@
# The default database to build and search.
+AUTOMAKE_OPTIONS = ../lib/ansi2knr
LOCATE_DB = $(localstatedir)/locatedb
localedir = $(datadir)/locale
@@ -16,5 +17,23 @@ LDADD = ../find/version.o ../lib/libfind.a @INTLLIBS@
$(PROGRAMS) $(LIBPROGRAMS): ../find/version.o ../lib/libfind.a
+updatedb: updatedb.sh
+ rm -f $@
+ find=`echo find|sed '$(transform)'`; \
+ frcode=`echo frcode|sed '$(transform)'`; \
+ bigram=`echo bigram|sed '$(transform)'`; \
+ code=`echo code|sed '$(transform)'`; \
+ sed \
+ -e "s,@""bindir""@,$(bindir)," \
+ -e "s,@""libexecdir""@,$(libexecdir)," \
+ -e "s,@""LOCATE_DB""@,$(LOCATE_DB)," \
+ -e "s,@""VERSION""@,@VERSION@," \
+ -e "s,@""find""@,$${find}," \
+ -e "s,@""frcode""@,$${frcode}," \
+ -e "s,@""bigram""@,$${bigram}," \
+ -e "s,@""code""@,$${code}," \
+ $(srcdir)/updatedb.sh > $@
+ chmod +x $@
+
install:
$(top_srcdir)/mkinstalldirs $(localstatedir)