summaryrefslogtreecommitdiff
path: root/locate/Makefile.am
diff options
context:
space:
mode:
authorJames Youngman <jay@gnu.org>2016-01-09 22:24:59 +0000
committerJames Youngman <jay@gnu.org>2016-01-10 17:23:13 +0000
commit89ec0211ce1fc15f2c5e5c45021300c6af7eb1ae (patch)
treee73fea276cccefd1d6b92f8f980bc1ad9e8c3e87 /locate/Makefile.am
parent69e308b286c3113dd04581e7323637481aa622da (diff)
downloadfindutils-89ec0211ce1fc15f2c5e5c45021300c6af7eb1ae.tar.gz
updatedb: Remove support for the old pre-4.0 database format.
* locate/testsuite/Makefile.am (EXTRA_DIST_EXP): Remove locate.gnu/old_prefix.exp and locate.gnu/oldformat.exp. (EXTRA_DIST_XO): Remove locate.gnu/old_prefix.xo and locate.gnu/oldformat.xo. * doc/find.texi (Database Formats): Remove the warning about old versions of locate failing to read the LOCATE02 database format. Mention that the slocate database format is also supported. (Old Database Format): Point out that updatedb will no longer produce the old format. (Invoking updatedb): Remove mention of the --old-format option. Remove mention of --dbformat=old. (Long File Name Bugs with Old-Format Databases): Remove this section. * locate/updatedb.sh: remove support for --dbformat=old and --old-format. (checkbinary): Don't look for the bigram and code binaries. * locate/updatedb.1: Explain that support for the old database format has been removed from updatedb and will shortly be removed from locate also. Remove the documentation for the removed option --old-format and mention of --dbformat-old. * locate/code.c: remove since this program was only used to generate old-format databases. * locate/bigram.c: remove since this program was only used to generate old-format databases. * po/POTFILES.in: Remove bigram.c and code.c. * locate/word_io.c (putword): Remove this function, since it was only needed for making old-format databases. * find/find.1 (NON-BUGS): Don't mention bigram.c and code.c in the example. * locate/locatedb.h: Remove declaration of putword, which has been deleted. * locate/Makefile.am (libexec_PROGRAMS): Remove bigram and code (since they were only used to generate old-format databases). (updatedb): Don't substitute @bigram@ and @code@. (code_SOURCES): Delete. * locate/testsuite/locate.gnu/old_prefix.exp: delete test case for the old database format. * locate/testsuite/locate.gnu/old_prefix.xo: Likewise. * locate/testsuite/locate.gnu/oldformat.exp: Likewise. * locate/testsuite/locate.gnu/oldformat.xo: Likewise. * TODO: manpages for bigram and code are no longer needed. * NEWS: Mention these changes.
Diffstat (limited to 'locate/Makefile.am')
-rw-r--r--locate/Makefile.am12
1 files changed, 2 insertions, 10 deletions
diff --git a/locate/Makefile.am b/locate/Makefile.am
index ba30d016..7b9a8f6c 100644
--- a/locate/Makefile.am
+++ b/locate/Makefile.am
@@ -4,12 +4,9 @@ AM_CFLAGS = $(WARN_CFLAGS)
LOCATE_DB = $(localstatedir)/locatedb
localedir = $(datadir)/locale
-AM_INSTALLCHECK_STD_OPTIONS_EXEMPT = \
- frcode$(EXEEXT) \
- code$(EXEEXT) \
- bigram$(EXEEXT)
+AM_INSTALLCHECK_STD_OPTIONS_EXEMPT = frcode$(EXEEXT)
bin_PROGRAMS = locate
-libexec_PROGRAMS = frcode code bigram
+libexec_PROGRAMS = frcode
bin_SCRIPTS = updatedb
man_MANS = locate.1 updatedb.1 locatedb.5
BUILT_SOURCES = dblocation.texi
@@ -18,7 +15,6 @@ CLEANFILES = updatedb
DISTCLEANFILES = dblocation.texi
locate_SOURCES = locate.c word_io.c
-code_SOURCES = code.c word_io.c
nodist_locate_TEXINFOS = dblocation.texi
AM_CPPFLAGS = -I$(top_srcdir)/lib -I../gl/lib -I$(top_srcdir)/gl/lib -DLOCATE_DB=\"$(LOCATE_DB)\" -DLOCALEDIR=\"$(localedir)\"
@@ -34,8 +30,6 @@ updatedb: updatedb.sh Makefile
rm -f $@
find=`echo find|sed '$(transform)'`; \
frcode=`echo frcode|sed '$(transform)'`; \
- bigram=`echo bigram|sed '$(transform)'`; \
- code=`echo code|sed '$(transform)'`; \
sed \
-e "s,@""bindir""@,$(bindir)," \
-e "s,@""libexecdir""@,$(libexecdir)," \
@@ -44,8 +38,6 @@ updatedb: updatedb.sh Makefile
-e "s,@""PACKAGE_NAME""@,$(PACKAGE_NAME)," \
-e "s,@""find""@,$${find}," \
-e "s,@""frcode""@,$${frcode}," \
- -e "s,@""bigram""@,$${bigram}," \
- -e "s,@""code""@,$${code}," \
-e "s,@""SORT""@,$(SORT)," \
-e "s,@""SORT_SUPPORTS_Z""@,$(SORT_SUPPORTS_Z)," \
$(srcdir)/updatedb.sh > $@