summaryrefslogtreecommitdiff
path: root/locate/Makefile.am
diff options
context:
space:
mode:
authorJames Youngman <jay@gnu.org>2016-01-24 23:15:57 +0000
committerJames Youngman <jay@gnu.org>2016-01-25 23:56:17 +0000
commit931fc967d17aea8cc851120c698fee6f1690b483 (patch)
treea905914b80c3ba37fe6aedcd467ec2b559e4c602 /locate/Makefile.am
parentf535461241e8f9c4738b435c6af892decb92d829 (diff)
downloadfindutils-931fc967d17aea8cc851120c698fee6f1690b483.tar.gz
updatedb: use the common definitions of the bug-report URL etc.
* locate/Makefile.am (updatedb): Substitute PACKAGE_BUGREPORT, PACKAGE_BUGREPORT_URL and PACKAGE_URL. We do this in the Makefile directly since updatedb.sh is not an output file generated directly by configure (instead, it's generated by the Makefile itself). * configure.ac (PACKAGE_BUGREPORT_URL): AC_DEFINE defines only a preprocessor macro. In order to get a similar effect for substituted output files, we need to use AC_SUBST. Hence introduce a shell variable $bugreport_url which we pass to both AC_SUBST and AC_DEFINE_UNQUOTED (replacing the previous call to AC_DEFINE). * locate/updatedb.sh (usage): Use PACKAGE_URL and PACKAGE_BUGREPORT_URL.
Diffstat (limited to 'locate/Makefile.am')
-rw-r--r--locate/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/locate/Makefile.am b/locate/Makefile.am
index 7b9a8f6c..0e9551b7 100644
--- a/locate/Makefile.am
+++ b/locate/Makefile.am
@@ -36,6 +36,9 @@ updatedb: updatedb.sh Makefile
-e "s,@""LOCATE_DB""@,$(LOCATE_DB)," \
-e "s,@""VERSION""@,$(VERSION)," \
-e "s,@""PACKAGE_NAME""@,$(PACKAGE_NAME)," \
+ -e "s,@""PACKAGE_BUGREPORT""@,$(PACKAGE_BUGREPORT)," \
+ -e "s,@""PACKAGE_BUGREPORT_URL""@,$(PACKAGE_BUGREPORT_URL)," \
+ -e "s,@""PACKAGE_URL""@,$(PACKAGE_URL)," \
-e "s,@""find""@,$${find}," \
-e "s,@""frcode""@,$${frcode}," \
-e "s,@""SORT""@,$(SORT)," \