summaryrefslogtreecommitdiff
path: root/locate/Makefile.am
diff options
context:
space:
mode:
authorJames Youngman <jay@gnu.org>2013-03-24 14:09:14 +0000
committerJames Youngman <jay@gnu.org>2013-03-24 14:09:14 +0000
commita917eb988fab87e47455c73731941d6fbfd1cf69 (patch)
tree31c388370002c76ccaea169c4d6f5211f030e15a /locate/Makefile.am
parent36b4a73e6367d7929b9d9919d497e05c68a390f6 (diff)
downloadfindutils-a917eb988fab87e47455c73731941d6fbfd1cf69.tar.gz
Bugfix to "make clean": do not delete header files.
* lib/Makefile.am (coverage-clean): Remove output files left behind by gcc -fprofile-arcs -ftest-coverage by using $(RM) with a glob pattern rather than a $(libfindtools_a_SOURCES.c=.gcno) Makefile substitution, because the latter caused us to delete header files entirely (their names do not end in .c). This had meant that it was impossible to compile findutils after "make clean". Bug report by David Gilbert. * find/Makefile.am (coverage-clean): Likewise. * xargs/Makefile.am (coverage-clean): Likewise. * locate/Makefile.am (coverage-clean): Likewise. * Makefile.am (coverage-clean): Likewise, but also do this in the subdirectories whose Makefile.am files are generated by gnulib-tool.
Diffstat (limited to 'locate/Makefile.am')
-rw-r--r--locate/Makefile.am18
1 files changed, 8 insertions, 10 deletions
diff --git a/locate/Makefile.am b/locate/Makefile.am
index 4792b8c6..d57b5d86 100644
--- a/locate/Makefile.am
+++ b/locate/Makefile.am
@@ -14,16 +14,7 @@ bin_SCRIPTS = updatedb
man_MANS = locate.1 updatedb.1 locatedb.5
BUILT_SOURCES = dblocation.texi
EXTRA_DIST = dblocation.texi locatedb.h updatedb.sh $(man_MANS)
-CLEANFILES = \
- updatedb \
- $(bigram_SOURCES:.c=.gcno) \
- $(bigram_SOURCES:.c=.gcda) \
- $(code_SOURCES:.c=.gcno) \
- $(code_SOURCES:.c=.gcda) \
- $(frcode_SOURCES:.c=.gcno) \
- $(frcode_SOURCES:.c=.gcda) \
- $(locate_SOURCES:.c=.gcno) \
- $(locate_SOURCES:.c=.gcda)
+CLEANFILES = updatedb
DISTCLEANFILES = dblocation.texi
locate_SOURCES = locate.c word_io.c
@@ -78,3 +69,10 @@ dist-hook: findutils-check-manpages
findutils-check-manpages:
$(top_srcdir)/build-aux/man-lint.sh $(srcdir) $(man_MANS)
+
+# Clean coverage files generated by running binaries built with
+# gcc -fprofile-arcs -ftest-coverage
+coverage-clean:
+ $(RM) *.gcno *.gcda *.gcov *.lcov
+
+clean-local: coverage-clean