summaryrefslogtreecommitdiff
path: root/locate/Makefile.am
diff options
context:
space:
mode:
authorKevin Dalley <kevin@seti.org>2000-01-27 03:24:13 +0000
committerKevin Dalley <kevin@seti.org>2000-01-27 03:24:13 +0000
commitb91d55816e2c8134e1930cdddb88dcb0589e9686 (patch)
tree0e9da8e2f885ea3749cfcc2c13504eadcfd1da5c /locate/Makefile.am
parent73d44f975ee8036eb510863ad64ac88747ce25ba (diff)
downloadfindutils-b91d55816e2c8134e1930cdddb88dcb0589e9686.tar.gz
* locate/Makefile.am, locate/locate.c, locate/code.c:
internationalized file.
Diffstat (limited to 'locate/Makefile.am')
-rw-r--r--locate/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/locate/Makefile.am b/locate/Makefile.am
index 86a139ed..a5875a2d 100644
--- a/locate/Makefile.am
+++ b/locate/Makefile.am
@@ -1,5 +1,6 @@
# The default database to build and search.
LOCATE_DB = $(localstatedir)/locatedb
+localedir = $(datadir)/locale
bin_PROGRAMS = locate
libexec_PROGRAMS = frcode code bigram
@@ -9,9 +10,9 @@ man_MANS = locate.1 updatedb.1 locatedb.5
EXTRA_DIST = locatedb.h updatedb.sh $(man_MANS)
CLEANFILES = updatedb
-INCLUDES = -I.. -I$(top_srcdir)/lib -DLOCATE_DB=\"$(LOCATE_DB)\"
+INCLUDES = -I$(top_srcdir)/lib -I../intl -DLOCATE_DB=\"$(LOCATE_DB)\" -DLOCALEDIR=\"$(localedir)\"
-LDADD = ../find/version.o ../lib/libfind.a
+LDADD = ../find/version.o ../lib/libfind.a @INTLLIBS@
$(PROGRAMS) $(LIBPROGRAMS): ../find/version.o ../lib/libfind.a