summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVitaliy Kirsanov <krokoziabla@yandex-team.ru>2019-04-29 12:48:24 +0300
committerErik de Castro Lopo <erikd@mega-nerd.com>2019-05-04 11:41:48 +1000
commit573dbc12ae3fc68e8edea08842f5864c553cd311 (patch)
treeb5d350a00d8b8b19dd10befe550fe5f86777416f /CMakeLists.txt
parent1cb968a7d45eea5f45451981c32df79e5b798739 (diff)
downloadflac-573dbc12ae3fc68e8edea08842f5864c553cd311.tar.gz
Use of BUILD_SHARED_LIBS added
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 1 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 886e9f58..6d3666b4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,10 +14,7 @@ endif()
if(CMAKE_C_COMPILER_ID MATCHES "GNU|Clang")
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Wextra -Wstrict-prototypes -Wmissing-prototypes -Waggregate-return -Wcast-align -Wnested-externs -Wshadow -Wundef -Wmissing-declarations -Winline")
-
- if(CMAKE_BULD_TYPE STREQUAL Release)
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -O3 -funroll-loops")
- endif()
+ set(CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE} -O3 -funroll-loops")
option(ENABLE_SSP "Enable GNU GCC stack smash protection" OFF)
endif()