summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMartijn van Beurden <mvanb1@gmail.com>2022-09-18 20:09:48 +0200
committerGitHub <noreply@github.com>2022-09-18 20:09:48 +0200
commitb175971f8087d38c003bac67bbd2c535e807d415 (patch)
tree246a84418a6a22081334301d0372fe05c099e39a /configure.ac
parentde058537cfb9e6a72dc664b31422ff3eff42bb7a (diff)
downloadflac-b175971f8087d38c003bac67bbd2c535e807d415.tar.gz
Include api dir in distribution
Also, don't create empty Doxygen tag and api directory
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d0f29e05..50f19efc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -375,6 +375,12 @@ if test "x$enable_doxygen_docs" != xfalse ; then
fi
AM_CONDITIONAL(FLaC__HAS_DOXYGEN, test -n "$DOXYGEN")
+if test "x$DOXYGEN" = "x"; then
+ AC_CHECK_FILE($srcdir/doc/FLAC.tag,[HAVE_PREBUILT_FLAC_TAG=yes])
+ AC_CHECK_FILE($srcdir/doc/api/modules.html,[HAVE_PREBUILT_API_DIR=yes])
+fi
+AM_CONDITIONAL(FLaC__HAS_PREBUILT_DOXYGEN, test "x$HAVE_PREBUILD_FLAG_TAG$HAVEPREBUILD_API_DIR" = "xyesyes")
+
AC_ARG_ENABLE(local-xmms-plugin,
AS_HELP_STRING([--enable-local-xmms-plugin],[Install XMMS plugin to ~/.xmms/Plugins instead of system location]),
[case "${enableval}" in