summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5487f97a..761dd49b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -219,7 +219,10 @@ if(BUILD_TESTING)
endif()
endif()
if(BUILD_EXAMPLES)
- set_target_properties(decode_file decode_file_cxx encode_file encode_file_cxx PROPERTIES FOLDER Examples)
+ set_target_properties(decode_file encode_file PROPERTIES FOLDER Examples)
+ if(BUILD_CXXLIBS)
+ set_target_properties(decode_file_cxx encode_file_cxx PROPERTIES FOLDER Examples)
+ endif()
endif()
if(BUILD_UTILS)
set_target_properties(flacdiff flactimer PROPERTIES FOLDER Utils)