summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index c771dfdc..5fa8d9db 100644
--- a/configure.ac
+++ b/configure.ac
@@ -593,9 +593,9 @@ dnl for correct FLAC_API
AC_CHECK_PROG(GIT_FOUND,git,yes)
if test x$GIT_FOUND$enable_version_from_git = "xyesyes"; then
- GIT_COMMIT_TAG=`git -C $srcdir describe --tags --exact-match 2>/dev/null`
- GIT_COMMIT_HASH=`git -C $srcdir log -1 --pretty=format:%h 2>/dev/null`
- GIT_COMMIT_DATE=`git -C $srcdir log -1 --pretty=format:%cd --date=format:%Y%m%d 2>/dev/null`
+ GIT_COMMIT_TAG=`git -C $srcdir --git-dir=.git describe --tags --exact-match 2>/dev/null`
+ GIT_COMMIT_HASH=`git -C $srcdir --git-dir=.git log -1 --pretty=format:%h 2>/dev/null`
+ GIT_COMMIT_DATE=`git -C $srcdir --git-dir=.git log -1 --pretty=format:%cd --date=format:%Y%m%d 2>/dev/null`
if test ${#GIT_COMMIT_HASH} = 8 && test ${#GIT_COMMIT_DATE} = 8; then
GIT_COMMIT_VERSION_AVAIL=yes
if test ${#GIT_COMMIT_TAG} != 0 ; then