summaryrefslogtreecommitdiff
path: root/doc/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'doc/CMakeLists.txt')
-rw-r--r--doc/CMakeLists.txt48
1 files changed, 10 insertions, 38 deletions
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
index 1f001707..df1f2775 100644
--- a/doc/CMakeLists.txt
+++ b/doc/CMakeLists.txt
@@ -12,43 +12,15 @@ if (NOT BUILD_DOXYGEN)
return()
endif()
-set(DOXYGEN_HTML_FOOTER doxygen.footer.html)
-set(DOXYGEN_GENERATE_TAGFILE FLAC.tag)
-
-if(CMAKE_VERSION VERSION_LESS 3.12)
- doxygen_add_docs(FLAC-doxygen
- ALL
- "${PROJECT_SOURCE_DIR}/include/FLAC"
- "${PROJECT_SOURCE_DIR}/include/FLAC++")
-else()
- doxygen_add_docs(FLAC-doxygen
- "${PROJECT_SOURCE_DIR}/include/FLAC"
- "${PROJECT_SOURCE_DIR}/include/FLAC++")
-
- install(DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}/html/"
- DESTINATION "${CMAKE_INSTALL_DOCDIR}/html/api")
+set(top_srcdir "${PROJECT_SOURCE_DIR}")
+configure_file(Doxyfile.in ${CMAKE_CURRENT_BINARY_DIR}/Doxyfile @ONLY)
-endif()
-install(FILES
- html/images/logo.svg
- html/images/logo130.gif
- html/changelog.html
- html/developers.html
- html/documentation.html
- html/documentation_bugs.html
- html/documentation_example_code.html
- html/documentation_format_overview.html
- html/documentation_tools.html
- html/documentation_tools_flac.html
- html/documentation_tools_metaflac.html
- html/faq.html
- html/favicon.ico
- html/features.html
- html/flac.css
- html/format.html
- html/id.html
- html/index.html
- html/license.html
- html/ogg_mapping.html
-DESTINATION "${CMAKE_INSTALL_DOCDIR}/html")
+add_custom_target(FLAC-doxygen ALL
+ COMMAND ${DOXYGEN_EXECUTABLE} Doxyfile
+ WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
+ COMMENT "Generating API documentation with Doxygen"
+ VERBATIM )
+
+install(DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}/api/"
+ DESTINATION "${CMAKE_INSTALL_DOCDIR}/api")