summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2021-08-26 11:50:05 +0100
committerSimon McVittie <smcv@collabora.com>2021-08-26 11:50:05 +0100
commit33bb8a85ecd8d40770d3d4e2bf22e157533701ad (patch)
tree606a22408fd6cd63c42a3db886f29c5ccd888e01 /Makefile.am
parentb246dc00e57d40b4745e77ff1249621e17016990 (diff)
downloadflatpak-33bb8a85ecd8d40770d3d4e2bf22e157533701ad.tar.gz
build: Move Makefile-*.am.inc up one level
This takes them out of the directory that is "owned" by the subproject, which will not be ignoring our Flatpak-specific generated files in its .gitignore, and puts them in a directory that is "owned" by Flatpak, which can ignore them. Signed-off-by: Simon McVittie <smcv@collabora.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index b8fea119..ba29a0c4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -98,7 +98,7 @@ libglnx_cflags := \
$(HIDDEN_VISIBILITY_CFLAGS) \
$(NULL)
libglnx_libs := $(BASE_LIBS)
-include subprojects/libglnx/Makefile-libglnx.am.inc
+include subprojects/Makefile-libglnx.am.inc
include common/Makefile.am.inc
include data/Makefile.am.inc
@@ -132,7 +132,7 @@ flatpak_bwrap_SOURCES = $(bwrap_SOURCES)
flatpak_bwrap_CFLAGS = $(AM_CFLAGS) $(bwrap_CFLAGS)
flatpak_bwrap_LDADD = $(AM_LDADD) $(bwrap_LDADD) $(CAP_LIB)
bwrapdir = $(libexecdir)
-include subprojects/bubblewrap/Makefile-bwrap.am.inc
+include subprojects/Makefile-bwrap.am.inc
endif # !WITH_SYSTEM_BWRAP