summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorIkey Doherty <ikey@solus-project.com>2017-01-18 22:35:08 +0000
committerAlexander Larsson <alexander.larsson@gmail.com>2017-01-19 10:05:13 +0100
commit3b64fbc4f51692ca821c1e197b671ac4b22bf726 (patch)
tree8f08e4251e31471e6e4982f207b99c329a498914 /Makefile.am
parentca107ebb16fced347dba4194181b05132fdcba59 (diff)
downloadflatpak-3b64fbc4f51692ca821c1e197b671ac4b22bf726.tar.gz
profile: Support alternative profile.d locations
Typically Linux distributions employ /etc/profile.d for system wide environment manipulation prior to multi-user initialisation. Modern distribution efforts split the vendor configuration from the local sysadmin configuration and data, by not using the /etc/ directories, for example. To enable this stateless pattern, this change adds a new --with-profile-dir option to use an alternative location, such as within /usr/share/. This ensures that the data (not configuration) is owned through the update process, and does not conflict with changes made locally to the system, enforcing domains of ownership. To preserve backwards compatible behaviour, the default directory remains set to /etc/profile.d. Signed-off-by: Ikey Doherty <ikey@solus-project.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 24b25287..c56a2ef1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -119,7 +119,7 @@ completiondir = $(datadir)/bash-completion/completions
completion_DATA = completion/flatpak
EXTRA_DIST += $(completion_DATA)
-profiledir = $(sysconfdir)/profile.d
+profiledir = $(PROFILE_DIR)
profile_DATA = flatpak.sh
EXTRA_DIST += \
profile/flatpak.sh.in \