summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThibault Saunier <tsaunier@gnome.org>2017-02-17 14:46:59 -0300
committerAlexander Larsson <alexander.larsson@gmail.com>2017-02-23 17:41:06 +0100
commit75388609b31f6c7a2d107721bdbbe6a71dc7d64e (patch)
treea3bbd67dfa75e89f8c02bb892e630cf14e6490f3 /Makefile.am
parent6125dabf58827dcb567953fc7e7310f82673b5be (diff)
downloadflatpak-75388609b31f6c7a2d107721bdbbe6a71dc7d64e.tar.gz
scripts: Add a script to allow bisecting failures
The CLI is pretty similare to the `git bisect` one and works as follow: $ flatpak-bisect org.app.App start # Update application and get the history $ flatpak-bisect org.app.App bad # Sets current commit as first bad commit $ flatpak-bisect org.app.App checkout GoodHash # Checkout the first known good commit $ flatpak-bisect org.app.App good # Sets GoodHash as first good commit ... Here it starts bisection and checkouts a commit on the way, the user should launch the app to check if the commit is good or bad and run: $ flatpak-bisect org.app.App good # if commit is good $ flatpak-bisect org.app.App bad # if commit is bad flatpak-bisect will tell when the first bad commit is found. Fixes https://github.com/flatpak/flatpak/issues/530
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 0aae5508..16f2be04 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -147,6 +147,9 @@ pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = flatpak.pc
EXTRA_DIST += flatpak.pc.in
+scriptsdir = $(bindir)
+scripts_SCRIPTS = scripts/flatpak-bisect
+
EXTRA_DIST += README.md
AM_DISTCHECK_CONFIGURE_FLAGS = \