summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorCosimo Cecchi <cosimo@endlessm.com>2016-12-31 10:01:51 -0800
committerAlexander Larsson <alexander.larsson@gmail.com>2017-01-16 11:36:48 +0100
commit78c3391b78f8ff8fb295fe328d36d0b29983801b (patch)
tree94fac405ffdf22b3514042c4343676f6477e11fb /Makefile.am
parent0fd09789871d1d7dcffa14615bbaf48e09708d30 (diff)
downloadflatpak-78c3391b78f8ff8fb295fe328d36d0b29983801b.tar.gz
system-helper: make sure to run with XDG_DATA_DIRS set
Otherwise we can see in the log that update-mime-database will complain about it not being set when installing an application using the system helper.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 0fa2da8d..3bdcce21 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -22,7 +22,10 @@ endif
SUBDIRS += po
%.service: %.service.in config.log
- $(AM_V_GEN) $(SED) -e "s|\@libexecdir\@|$(libexecdir)|" -e "s|\@extraargs\@||" $< > $@
+ $(AM_V_GEN) $(SED) -e "s|\@libexecdir\@|$(libexecdir)|" \
+ -e "s|\@localstatedir\@|$(localstatedir)|" \
+ -e "s|\@externalinstalldir\@|$(EXTERNAL_INSTALL_DIR)|" \
+ -e "s|\@extraargs\@||" $< > $@
dbus_servicedir = $(DBUS_SERVICE_DIR)
service_in_files = $(NULL)