summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMatthew Leeds <matthew.leeds@endlessm.com>2020-06-18 20:56:47 -0700
committerAlexander Larsson <alexander.larsson@gmail.com>2020-06-23 09:37:10 +0200
commit9caf664fabc911419cc483125bf543c4550604c7 (patch)
treefce465ba328c474ac2f3b10376836f71094e9362 /Makefile.am
parente84b75629dd5c7a121cc4cb04968feca05c7a59f (diff)
downloadflatpak-9caf664fabc911419cc483125bf543c4550604c7.tar.gz
Add systemd units to sideload from hotplugged USBs
Currently with the sideload implementation of offline updates you have to manually create a symlink to your USB drive to sideload from it, which is a regression compared to the previous implementation which scanned all mounted filesystems in OstreeRepoFinderMount in libostree. So this commit adds a few systemd units and a bash script so that any time a USB drive is plugged in and automatically mounted by udisks, a symlink to it is created in /run/flatpak/sideload-repos. When the drive is unplugged the symlink is removed. However this solution still has a lot of moving parts, so we may want to instead have libflatpak use GVolumeMonitor and find the mounted filesystems itself; see https://github.com/flatpak/flatpak/issues/3705 Fixes https://github.com/flatpak/flatpak/issues/3490
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 4c4cc97d..2d59b92e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -25,11 +25,13 @@ SUBDIRS += po
%.service: %.service.in config.log
$(AM_V_GEN) $(SED) -e "s|\@libexecdir\@|$(libexecdir)|" \
-e "s|\@localstatedir\@|$(localstatedir)|" \
+ -e "s|\@media_dir\@|$(RUN_MEDIA_DIR)|" \
-e "s|\@extraargs\@||" $< > $@
dbus_servicedir = $(DBUS_SERVICE_DIR)
service_in_files = $(NULL)
dbus_service_DATA = $(NULL)
+systemdsystemunit_DATA = $(NULL)
systemduserunit_DATA = $(NULL)
CLEANFILES += $(dbus_service_DATA)
CLEANFILES += $(systemduserunit_DATA)
@@ -101,6 +103,7 @@ include oci-authenticator/Makefile.am.inc
include icon-validator/Makefile.am.inc
include revokefs/Makefile.am.inc
include selinux/Makefile.am.inc
+include sideload-repos-systemd/Makefile.am.inc
include tests/Makefile.am.inc
if !WITH_SYSTEM_DBUS_PROXY